incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juergen Schmidt <jogischm...@googlemail.com>
Subject Re: [HEADS UP] Re: [UPDATE SERVICE] proposal for a AOO 3.4 update service
Date Tue, 22 May 2012 14:05:16 GMT
Am Dienstag, 22. Mai 2012 um 15:53 schrieb Paulo de Souza Lima:
> 2012/5/22 Oliver-Rainer Wittmann <orwittmann@googlemail.com>
> 
> > Hi,
> > 
> > 
> > On 22.05.2012 14:56, Oliver-Rainer Wittmann wrote:
> > 
> > > On 22.05.2012 14:47, Paulo de Souza Lima wrote:
> > > 
> > > > 2012/5/22 Oliver-Rainer Wittmann<orwittmann@**googlemail.com<orwittmann@googlemail.com>
> > > > > 
> > > > 
> > > > 
> > > > 
> > > > > > wrote:
> > > > > > 
> > > > > > Oliver-Rainer Wittmann wrote:
> > > > > > 
> > > > > > > 
> > > > > > > Thus, you got an error in the AOO 3.4 update functionality,
because
> > > > > > > > you
> > > > > > > > have an own redirect from openoffice.org to another
host. Right?
> > > > > > > > Does
> > > > > > > > the
> > > > > > > > update functionality works, if you do not have your
own redirect? I
> > > > > > > > am
> > > > > > > > asking in order to be sure that I got the right message.
> > > > > > > > 
> > > > > > > 
> > > > > > > It worked correctly. I had setup that redirect on my machine
just to
> > > > > > > moderate lists on the legacy infrastructure after the DNS
change
> > > > > > > (Oracle
> > > > > > > to
> > > > > > > Apache) had been completed; it is now useless of course.
When I
> > > > > > > removed
> > > > > > > my
> > > > > > > redirect, everything worked as expected and I received
a message
> > > > > > > saying
> > > > > > > that no updates were available.
> > > > > > > 
> > > > > > > 
> > > > > > > Worked very nicely for me using AOO 3.4. Will try later
with an OOo
> > > > > > 3.3
> > > > > > machine when it is awake. Congratulations!
> > > > > > 
> > > > > > 
> > > > > > Thanks for the test.
> > > > > 
> > > > > The update service for installed OOo 3.3 instance has not be
> > > > > established,
> > > > > yet.
> > > > > 
> > > > > Best regards, Oliver.
> > > > Hi. I tried here in my office, through an authenticated proxy. It works,
> > > > but it asks for the proxy user and password many times, even if I check
> > > > the
> > > > "Enable password" option.
> > > > 
> > > 
> > > Hm..
> > > As far as I know only one HTTP GET request is performed internally by AOO
> > > 3.4.
> > > May be due to the redirects more requests are made - I'll have to check
> > > it.
> > > 
> > 
> > 
> > I have checked it.
> > Due to the redirect three HTTP GET request are performed.
> > The first goes to http://update38.services.**openoffice.org/**
> > ProductUpdateService/check.**Update<http://update38.services.openoffice.org/ProductUpdateService/check.Update>,
> > the second to http://openoffice.org/**projects/update38/**
> > ProductUpdateService/check.**Update<http://openoffice.org/projects/update38/ProductUpdateService/check.Update>and
the final one to
> > http://www.openoffice.org/**projects/update38/**
> > ProductUpdateService/check.**Update<http://www.openoffice.org/projects/update38/ProductUpdateService/check.Update>
> > The same URLs that Andrea already figured out.
> > 
> > 
> > I think the "Remember password" option is part of your proxy software.
> > > Thus, I
> > > do not think that its functionality is related to AOO 3.4.
> > > 
> > 
> > May be each HTTP GET request needs to be authenticated in your proxy
> > software.
> > 
> > Best regards, Oliver.
> 
> Suggestion: maybe including fields for proxy user and password in Tools >
> Option > Internet > Proxy. An option for socks proxy shoud be usefull also.
> 
> 

I think it is already possible to configure a proxy. And in case no proxy is configured in
the office the system proxy is used as far as I know. Maybe we have a minor problem here with
the new WebDAV/http implementation.

But in general a proxy can be configured.

Juergen 
> 
> -- 
> Paulo de Souza Lima
> http://almalivre.wordpress.com
> Curitiba - PR
> Linux User #432358
> Ubuntu User #28729
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message