incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer ...@a-w-f.de>
Subject Re: Building AAO from source...
Date Wed, 23 May 2012 15:57:26 GMT
Someone said my name?  I don't know if I can help, but I will try.

On 23.05.2012 17:33, Kay Schenk wrote:
> Nelson--
>
> I don't know if I can help much with this, but the most recent install
> guide is at:
>
> http://wiki.services.openoffice.org/wiki/Documentation/Building_Guide_AOO
>
> and I do recall at first this very solenv was causing issues though I
> don't recall what the solution was.
>
> Buildbot info is at:
>
> http://ci.apache.org/buildslaves/bb-vm2_ubuntu_32bit
>
> I think Andre Fisher did a lot of work on this and the Linux guide
> linked on this page...if you need more help.
>
> On 05/20/2012 10:11 AM, Nelson Marques wrote:
>> Hi,
>>
>> I've setup a small environment to test some building of AAO, but I'm
>> somehow stuck and I'm not really sure why I'm having a weird behavior.
>>
>> I'm not really sure what is causing this, but the path translation is
>> all twisted, ex:
>> /home/nmarques/aoo/aoo-3.4.0/main/solenv/unxlngxpro/incnc/mywlrld.mk
>>
>> I assume this would be something like:
>> /home/nmarques/aoo/aoo-3.4.0/main/solenv/unxlngxpro/inc/myworld.mk
>>
>> Which means something is very wrong... full output bellow... My
>> configure options are:
>>
>> ./configure --prefix=/opt/my-aoo \
>> --with-system-libs \
>> --with-mingwin=/usr/bin/i686-pc-mingw32-c++ \
>> --with-vendor="SOME-TEST" \
>> --enable-gstreamer \
>> --enable-cairo \
>> --enable-opengl \
>> --enable-dbus \
>> --enable-category-b \
>> --enable-bundled-dictionaries
>>
>>
>> [nmarques@odin instsetoo_native]# build --all
>> build -- version: 275224
>>
>>
>> =============
>> Building module solenv
>> =============
>>
>> Entering /home/nmarques/aoo/aoo-3.4.0/main/solenv
>>
>> dmake: /home/nmarques/aoo/aoo-3.4.0/main/solenv/inc/settings.mk:
>> line 618: Error: -- Include file

Nelson, can you show us this line 618 in settings.mk?
Does it say .../inc/... or .../incnc/... ?  If the later, does fixing 
this line fix the build problem?

-Andre

>> /home/nmarques/aoo/aoo-3.4.0/main/solenv/unxlngxpro/incnc/mywlrld.mk,
>> not found
>> ---* SETTINGS.MK *---
>>
>> 1 module(s):
>> solenv
>> need(s) to be rebuilt
>>
>> Reason(s):
>>
>> ERROR: error 65280 occurred while making
>> /home/nmarques/aoo/aoo-3.4.0/main/solenv
>>
>> When you have fixed the errors in that module you can resume the build
>> by running:
>>
>> build --all:solenv
>>
>>
>>
>>
>

Mime
View raw message