incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: AO 3.4: Java Extension and HeadlessException
Date Wed, 16 May 2012 17:08:02 GMT
Hi Andor,

On Wed, May 16, 2012 at 03:41:08PM +0000, Andor E wrote:
> I'm not sure, how this can be a bug in my code. 

I don't mean a bug *in* your code, I mean a bug *with* your Java
application in the environment you are testing it.

> The very same code runs fine with OOo 3.2.1 and OOo 3.3. 

Did you test this in the very same machine you're seeing this bug?

> What stymies me, is, why the JRE seems to run headless.

And that's why I say a bug with your Java application in your
environment. In my environment, your extension can be installed and it
runs, and your Java application also works.

Your backtrace is pretty clear:

de.muenchen.allg.itd51.wollmux.dialog.WollMuxBar.createGUI(WollMuxBar.java:480)

you hit the bug in your Java application when you try to instantiate the
Swing JFrame, IMHO it has nothing to do with Apache OpenOffice, your
application is running in other process with its own JVM, etc. And
bootstrapping the office should have no influence at all...


> 
> The WollMux quickstarter is completely distinct from the AOO
> quickstarter. It tries to keep the soffice process alive. I will make
> another test with both quickstarters disabled.

If nothing works, I'd suggest as in my previous mail, and test with
another JVM/jdk.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message