incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chaitanya Sevak <3chaita...@gmail.com>
Subject Saved RTF has issue in encoding Latin1 characters
Date Thu, 12 Apr 2012 10:08:35 GMT
Hi,

In Open Office 3.2 windows version, I observed issue in RTF file.
You may open Open Office writer and copy -paste this string -- šbkeâ}sKeve
(Note - this is not garbage data but meaningful asian word if used with
monolingual font - APS-DV-PRAKASH)
Then save the file as RTF and check the RTF code using any notepad
application.

It saves the non english characters as unicode values and HEX code in
following fashion
For character š - RTF file code shows - \u353\'3f
For character â - RTF code shows - \u226\'3f
Like this for every special character the unicode value is correct but for
each such character HEX code is incorrect and that is - \'3f for every
special character.

Same string is stored in AbiWord shows proper HEX values-
For character š - RTF file code shows - \u353\'9a
For character â - RTF code shows - \u226\'e2
Which are correct as per wiki link.
http://en.wikipedia.org/wiki/Windows-1252

This does not give any issue in rendering the string in Open Office writer
but if this file is used in other programs which strictly uses HEX values,
we hit with issue. (Anyways incorrect HEX values is definitely an issue!)

Thanks,
Chaitanya

*Was reported on forum at -
http://www.oooforum.org/forum/viewtopic.phtml?t=153638*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message