incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xia Zhao <lilyzh...@gmail.com>
Subject RC Build Verification Test Report
Date Tue, 24 Apr 2012 09:47:54 GMT
Hi all,

I summary the RC build verification report got in ooo-qa list here:
https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+3.4+RC+Build+Test+Report

In general, below issues found RC build (r1325589):

   1. Simplified Chinese, Traditional Chinese and Brazilian language
   packages don't work on Linux platform. This may due to the same problem
   that using "-" in filed name, which occurred for full native language
   packages before. If we don't plan publish language package for AOO 3.4,
   this issue can defer. If publish, i119210 may have to be fixed.


   - i119210: Cannot switch UI languages to zh_CN on Linux if installed
   en_US then zh_CN language package.

      2. Upgrade issues on Linux platform:

   - i119158: Cannot upgrade integrated menu from 3.3 to 3.4 on
   Redhat6.1/Suse11.
   - i119162: Two copies of ooobasis packages after upgrade from ooo3.3 to
   3.4

      The two ones are known issues and recored in installation guide and
release note(I didn't check them so far but be supposed do this way). No
ship stopper.

   - i119258: Languages remain in the languages list though the
   dictionaries cannot be used after upgrade from OOo 3.3

       This issue is something related with Linux upgrade. User can remove
the invalid packages manually to fix this problem.

      3. Two functional regression defects:

   - i119238: The title and author font is too small if creating one
   presentation from template except for original ones. I have no choice to
   verify which build introduce this regression but may not RC build.
   - i119239: Blue background in notes view. Same as above.

       4. Upgrade from OO 3.2 to AOO 3.4

   -  i119271: Spell checker doesn't work if upgrade from OOo 3.2 to AOO
   3.4.  This one should be checked.

       5. Install/reinsatll round trip issue.
           On Windows XP SP3, Clean install AOO 3.4 English package. And
the other language packages. Then uninstall AOO 3.4. Now the language
packages for AOO 3.4 are still there. Try to install OOo 3.3 now. After
install, I tried to new document/presentation/spreadsheet,freeze and no
response. I tried the scenarios three times and got same result.  Then I
tried to upgrade to AOO 3.4 again, always be told that I should exit AOO
3.4 quick start first. It seems the below scenario doesn't work: OOo 3.3
plus AOO 3.4 language packages.

The above scenario is seldom be used and may be record in somewhere like
forum etc. No ship stopper.

So only one thing need check is i119271. I will double check it against new
RC2 build: r1327774.

Anyway, based on above testing result, I give +1 for RC build voting.

Best regards,

Lily

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message