incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JH Chen <chenj...@gmail.com>
Subject Re: cannot find JRE ?
Date Thu, 19 Apr 2012 05:40:42 GMT
The extension installed and worked without any issue in my AOO3.4 build. I
am using the following JVM.

java version "1.6.0"
Java(TM) SE Runtime Environment (build
pwa6460sr9ifix-20110211_02(SR9+IZ94423))
IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Windows 7 amd64-64
jvmwa6460sr9-20101
124_69295 (JIT enabled, AOT enabled)
J9VM - 20101124_069295
JIT  - r9_20101028_17488ifx2
GC   - 20101027_AA)
JCL  - 20110211_02

On Thu, Apr 19, 2012 at 1:17 PM, Shenfeng Liu <liushenf@gmail.com> wrote:

> Jin Hua have no problem in his machine with IBM JRE recognized.
> I will try to install a new version to check if it works.
>
> - Simon
>
> 2012/4/19 Dennis E. Hamilton <dennis.hamilton@acm.org>
>
> > In a different context, there was found to be code that verifies a vendor
> > string in determining detection of the Java installation.  It was
> necessary
> > to adjust code to accept Oracle corporation as well as Sun Microsystems,
> a
> > change that occurs in Java 7 distributions.
> >
> > Simon is using an IBM-produced JRE.
> >
> > It is difficult to imagine this being the problem.  Still, it could
> > certainly account for seeing one of those "works for me" mysteries.
> >
> >  - Dennis
> >
> >
> >
> > -----Original Message-----
> > From: Andre Fischer [mailto:af@a-w-f.de]
> > Sent: Wednesday, April 18, 2012 18:42
> > To: ooo-dev@incubator.apache.org
> > Subject: Re: can not find JRE ?
> >
> > Hi Simon,
> >
> > on my machine it looks like this:
> > after opening Tools->Options->OpenOffice.org->Java it takes a short time
> > to populate the list of available JREs.  From these I can select the one
> > to use, no need to enter a path manually.
> > The paths of some available JREs (all are 32 bit) are
> >
> >     c:\Program Files (x86)\Java\jdk1.6.0_27\jre
> >     c:\Program Files (x86)\Java\jre7
> >
> > Regards,
> > Andre
> >
> > On 18.04.2012 21:13, Shenfeng Liu wrote:
> > > Sorry, that I clicked "Send" in mistake before I finish. So let me
> > rewrite:
> > >
> > > I installed the latest build successfully, and want to try the IBM
> > > Connection extension. Since it is Java based, I need to config the JRE
> > > firstly.
> > > In the Options dialog, Use a JRE check box was already on, but there is
> > no
> > > JRE listed available. Then I clicked Add button to browse to my JRE
> > folder,
> > > but no matter which level I select, I was always told "The folder you
> > > selected does not cotain a Java runtime environment."
> > > Running "Java -version" in cmd I got the following (I'm using WinXP
> SP2):
> > >
> > > java version "1.5.0"
> > > Java(TM) 2 Runtime Environment, Standard Edition (build
> > > pwi32devifx-20071025 (SR
> > > 6b))
> > > IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32
> > > j9vmwi3223-2007100
> > > 7 (JIT enabled)
> > > J9VM - 20071004_14218_lHdSMR
> > > JIT  - 20070820_1846ifx1_r8
> > > GC   - 200708_10)
> > > JCL  - 20071025
> > >
> > >
> > > Not sure if any thing I missed... Can any one help? Thanks very much!
> > >
> > > - Simon
> > >
> > >
> > > 2012/4/18 Shenfeng Liu<liushenf@gmail.com>
> > >
> > >> I installed the latest build successfully, and want to try the IBM
> > >> Connection extension. Since it is Java based, I need to config the JRE
> > >> firstly.
> > >> In the Options dialog, Use a JRE check box was already on, but there
> is
> > no
> > >> JRE listed available. Then I clicked Add button to browse to my JRE
> > >>
> > >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message