incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Fisher <dave2w...@comcast.net>
Subject Re: Help with MacOSX Build
Date Mon, 23 Apr 2012 04:34:39 GMT

On Apr 22, 2012, at 8:20 PM, Chao Huang wrote:

> I build out the latest aoo3.4 source code (revision 1329048) on my Mac OS X
> 10.6.8. It's very simple to follow the build guide "
> http://wiki.services.openoffice.org/wiki/Documentation/Building_Guide/Building_on_MacOSX
> ".
> 
> Here is my configure args :
> ./configure --with-dmake-url="
> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2" \
>            --with-epm-url="
> http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz" \
>            --disable_mozilla \
>            --disable-build-mozilla \
>            --enable-verbose \
>            --enable-category-b\
>            --enable-minimizer\
>            --enable-presenter-console\
>            --enable-wiki-publisher

I used:

./configure --with-dmake-url=http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2
  \
	--with-epm-url=http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz \
	--disable-build-mozilla \
	--enable-verbose \
	--enable-category-b \
	--enable-minimizer \
	--enable-presenter-console
	--enable-wiki-publisher

So, I'll change to add --disable_mozilla tomorrow and report back.

Thanks ans Regards,
Dave

> 
> 
> 2012/4/23 Dave Fisher <dave2wave@comcast.net>
> 
>> I have some questions about building for MacOSX
>> 
>> The project wiki is not very clear. [1][2]
>> 
>> (1) Where can I get a copy of Mac 10.4 SDK?
>> 
>> (2) What version of XCode should I install?
>> 
>> Google answers (1) and (2) with the TDF's wiki[2]. I downloaded XCode
>> 3.2.6 for my MacOSX 10.6.8 system and checked the Mac 10.4 SDK option
>> during installation. Took a couple of hours, but worked fine.
>> 
> 
> You can find Xcode 3.2.6 installation package in the Mac OS X 10.6 disk.
> Please select "Mac OS X 10.4 Support" in step "Installation Type".
> 
> 
>> (3) dmake and epm. It should be more obvious that the config step can
>> build these.
>> 
> 
> Please set them in config args.
> 
> 
>> 
>> (4) The Java 1.6 vs. 1.5 issue is confusing as well. I'm on 10.6.8 and
>> have Java SE 1..6.0_31- yes I applied the Flashback update. Will everything
>> work ok?
>> 
> 
> It's OK for me to build source code with Java 1.6.0_31. I updated the JVM
> to the latest one with "Software Update".
> 
> 
>> (5) I did the autoconfig and bootstrap i put the files from
>> http://www.openoffice.org/tools/moz_prebuild/OOo3.2/ into moz/zipped/ as
>> the config process suggested. I started the build, after quite awhile I had
>> an error with moz. I am unsure what to do next
>> 
> 
> I disabled mozilla in configure.
> 
> 
>> 
>> Here is my moz directory structure:
>> 
>> ./extractfiles.mk
>> ./makefile.mk
>> ./patches/arm_build_fix.patch
>> ./patches/brokenmakefile.patch
>> ./patches/consecutive_ldap_queries.patch
>> ./patches/cygwin_paths_in_ldap_sdk.patch
>> ./patches/dtoa.patch
>> ./patches/embed_manifest.patch
>> ./patches/gcc46.patch
>> ./patches/index.txt
>> ./patches/link_fontconfig.patch
>> ./patches/no_core_abspath_in_nss.patch
>> ./patches/nss_linux.patch
>> ./patches/respect_disable_pango.patch
>> ./patches/wchart_on_msvc8.patch
>> ./prj/build.lst
>> ./prj/d.lst
>> ./README
>> ./seamonkey-source-1.1.14.patch
>> ./unxmacxi.pro/inc/myworld.mk
>> ./zipped/MACOSXGCCIinc.zip
>> ./zipped/MACOSXGCCIlib.zip
>> ./zipped/MACOSXGCCIruntime.zip
>> 
>> Here is the output:
>> 
>> Entering /Users/dave/Documents/AOO/aoo-3.4.0/main/moz
>> 
>> mkout -- version: 1.8
>> Use of internal mozilla is disabled.
>> 
>> Entering /Users/dave/Documents/AOO/aoo-3.4.0/main/moz/zipped
>> 
>> -----------------------------------------------
>> Error: No makefile.mk found!
>> -----------------------------------------------
>> force_dmake_to_error
>> dmake:  Error executing 'force_dmake_to_error': No such file or directory
>> dmake:  Error code -1, while making 'no_traget'
>> 
>> 1 module(s):
>>       moz
>> need(s) to be rebuilt
>> 
>> Reason(s):
>> 
>> ERROR: error 65280 occurred while making
>> /Users/dave/Documents/AOO/aoo-3.4.0/main/moz/zipped
>> 
>> When you have fixed the errors in that module you can resume the build by
>> running:
>> 
>>       build --all:moz
>> 
>> Regards,
>> Dave
>> 
>> [1]
>> http://wiki.services.openoffice.org/wiki/Documentation/Building_Guide_AOO/Building_on_MacOsX
>> [2]
>> http://wiki.services.openoffice.org/wiki/Documentation/Building_Guide/Building_on_MacOSX
>> [3]
>> http://wiki.documentfoundation.org/Development/Install_Mac_OS_X_Dependencies
> 
> 
> 
> 
> -- 
> Best regards,
> Chao Huang


Mime
View raw message