incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kay Schenk <kay.sch...@gmail.com>
Subject Re: Linux builds
Date Tue, 10 Apr 2012 16:09:42 GMT


On 04/10/2012 03:05 AM, RGB ES wrote:
> El d�a 10 de abril de 2012 09:12, J�rgen Schmidt
> <jogischmidt@googlemail.com>  escribi�:
>>
>> I am no expert in this area but would it be possible to define a meta
>> package that do some clean unintall of older basis packages and desktop
>> integrations?
>>
>
> Some time ago, openSUSE replaced their go-oo build with LibO (without
> a warning to the users...). The update cleaned previous installs so
> some kind of scripting magic associated with the new packages should
> be possible.

I haven't tried to install AOO in "update mode" by folloiwng these 
instructions:  (issue 119162 -- 
https://issues.apache.org/ooo/show_bug.cgi?id=119162)

* upgrade to 3.4 by command: rpm -Uvh o*.rpm

(I installed it in a separate directory as a "new " install a while back.)

I will do this today, but...

if there IS a problem with installing over 3.3, is there some reason we 
can't tell Linux users to de-install 3.3 first before installing 3.4 as 
part of the release notes?

Scripting this de-installation might be a bit tricky depending on 
distro, but all Linux users should know how to de-install on their own.

and re openSuSE and maybe others -- the symlink from the original OOo 
main, soffice, noramlly "/usr/bin/soffice", will still need to be 
investigated -- maybe also include in release notes.


>
> Regards
> Ricardo

-- 
------------------------------------------------------------------------
MzK

"Women and cats will do as they please,
  and men and dogs should relax and get used to the idea."
                                     -- Robert Heinlein

Mime
View raw message