incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From J├╝rgen Schmidt <jogischm...@googlemail.com>
Subject Re: Previous extension won't work against AOO 3.4?
Date Thu, 05 Apr 2012 10:54:07 GMT
On 4/5/12 12:05 PM, xia zhao wrote:
> Juergen,
>
> How to understand the comments at:
> https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+3.4+Unofficial+Developer+Snapshots
>
> "
> Please also notice that extensions can't be migrated because of underlying
> technical changes (removing Berkeley DB)".
>
> So it means all the previous extension developed against previous OOo
> version can't work against AOO 3.4?

no that is false and a misleading information, I will change it.

At the beginning we had problems with the migration of installed 
extensions. But this is fixed now and former installed extensions should 
be migrated.


And extension developed for earlier OpenOffice versions should still 
work. But it can always happen that other changes will make problems. 
Extensions in C++ can make more problems but often a simple rebuild 
should solve such problems

Today I would always suggest to use a max version dependency and would 
check my extension for the next version. This way it is possible to 
ensure an always working extension.

Juergen


>
>
> Lily
>


Mime
View raw message