incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: Linux builds
Date Mon, 09 Apr 2012 23:12:46 GMT
On Mon, Apr 09, 2012 at 12:16:38PM +0200, J├╝rgen Schmidt wrote:
> 
> Does anybody have tested an upgrade installation with these new
> Linux packages and can verify the reported problem, see
> https://issues.apache.org/ooo/show_bug.cgi?id=119162
> 
> I think we haven't noticed this problem before and I would be
> interested if others can confirm this problem.
> 
> I will be offline for ~1 day because of traveling and I will make
> the call for VOTE depending on the feedback from you.

Old basis package set remaining is the default behaviour, at least
tested with OOo 3.0.0. On Fedora 16:

- install OOo 3.0.0 (OOO300_m9 9358)
- install OOo 3.1.1 (OOO310_m19 9420)

1) there is an issue with the desktop integration, same for AOO
2) the old basis3.0 remains:

/opt/openoffice.org/basis3.0
/opt/openoffice.org/basis3.1

All ooobasis3.0 packages are kept.
Only the following packages are updated:

Updating:
 openoffice.org-ure     
 openoffice.org3        
 openoffice.org3-base   
 openoffice.org3-calc   
 openoffice.org3-dict-en
 openoffice.org3-dict-es
 openoffice.org3-dict-fr
 openoffice.org3-draw   
 openoffice.org3-en-US  
 openoffice.org3-impress
 openoffice.org3-math   
 openoffice.org3-writer 

See http://people.apache.org/~arielch/packages/yum-update-3.0.0-3.1.1.txt

Update to OOo 3.2.1 (000320_m18 9502) leaves:

/opt/openoffice.org/basis3.0
/opt/openoffice.org/basis3.1
/opt/openoffice.org/basis3.2

http://people.apache.org/~arielch/packages/yum-update-3.1.1-3.2.1.txt

Update to OOo 3.3.0 (000330_m20 9567) leaves:

/opt/openoffice.org/basis3.0
/opt/openoffice.org/basis3.1
/opt/openoffice.org/basis3.2
/opt/openoffice.org/basis3.3

http://people.apache.org/~arielch/packages/yum-update-3.2.1-3.3.0.txt

Update AOO 340m1(Build:9590) rev.1310206 leaves:

/opt/openoffice.org/basis3.0
/opt/openoffice.org/basis3.1
/opt/openoffice.org/basis3.2
/opt/openoffice.org/basis3.3
/opt/openoffice.org/basis3.4

http://people.apache.org/~arielch/packages/yum-update-3.3.0-AOO3.4.0.txt

In every case, the application can be launched with
/opt/openoffice.org3/program/soffice

The previous desktop integration package has to be removed in order to
install the new one.

--------------------------------------------------------

Conclusion: 

1) leaving remaining basis packages is the behaviour since OOo 3.0.0. 
2) desktop integration install failing happens since OOo 3.0.0
3) The real issue (may be unrelated to 1 and 2) is:


[ariel@localhost ~]$ openoffice.org3
Application Error

Fatal exception: Signal 6
Stack:
/opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3(+0x34f5b)[0x7fedaf274f5b]
/opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3(+0x35f20)[0x7fedaf275f20]
/opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3(+0x35fdf)[0x7fedaf275fdf]
/lib64/libc.so.6[0x3456836300]
/lib64/libc.so.6(gsignal+0x35)[0x3456836285]
/lib64/libc.so.6(abort+0x17b)[0x3456837b9b]
/opt/openoffice.org3/program/../basis-link/program/libvcl.so(+0x15d3c2)[0x7fedabb9d3c2]
/opt/openoffice.org3/program/../basis-link/program/libsofficeapp.so(+0x211c6)[0x7fedaefd81c6]
/opt/openoffice.org3/program/../basis-link/program/libvcl.so(+0x18740f)[0x7fedabbc740f]
/opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3(+0x35fb3)[0x7fedaf275fb3]
/lib64/libc.so.6[0x3456836300]
/opt/openoffice.org3/program/../basis-link/program/deployment.uno.so(+0x4d8f2)[0x7fed964c08f2]
/opt/openoffice.org3/program/../basis-link/program/deployment.uno.so(+0x51f2f)[0x7fed964c4f2f]
/opt/openoffice.org3/program/../basis-link/program/deployment.uno.so(+0x51159)[0x7fed964c4159]
/opt/openoffice.org3/program/../basis-link/program/libdeploymentmisc.so(_ZN7dp_misc16syncRepositoriesERKN3com3sun4star3uno9ReferenceINS2_3ucb19XCommandEnvironmentEEE+0x308)[0x7fedae021558]
/opt/openoffice.org3/program/../basis-link/program/libsofficeapp.so(+0x3b730)[0x7fedaeff2730]
/opt/openoffice.org3/program/../basis-link/program/libsofficeapp.so(+0x2abe9)[0x7fedaefe1be9]
/opt/openoffice.org3/program/../basis-link/program/libvcl.so(+0x1871c8)[0x7fedabbc71c8]
/opt/openoffice.org3/program/../basis-link/program/libvcl.so(_Z6SVMainv+0x1d)[0x7fedabbc733f]
/opt/openoffice.org3/program/../basis-link/program/libsofficeapp.so(soffice_main+0x9c)[0x7fedaf00a5fc]
/opt/openoffice.org3/program/soffice.bin(main+0xb)[0x40102b]
/lib64/libc.so.6(__libc_start_main+0xed)[0x345682169d]
/opt/openoffice.org3/program/soffice.bin[0x400f59]
/opt/openoffice.org3/program/soffice: line 122:  9294 Aborted                 "$sd_prog/$sd_binary"
"$@"


After erasing all the old basis packages, AOO can be launched (no need
to reinstall any package from AOO 3.4)
http://people.apache.org/~arielch/packages/yum-erase-old-basis.txt


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message