incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Weir <robw...@apache.org>
Subject Re: [RELEASE]: Bug 118366 - JAVA UNO API: XTextRange.getString returns correct String only after some delay
Date Thu, 01 Mar 2012 16:34:04 GMT
On Thu, Mar 1, 2012 at 11:07 AM, Jürgen Schmidt
<jogischmidt@googlemail.com> wrote:
> On 3/1/12 5:00 PM, Rob Weir wrote:
>>
>> On Thu, Mar 1, 2012 at 7:37 AM, Jürgen Schmidt
>> <jogischmidt@googlemail.com>  wrote:
>>>
>>> Hi
>>>
>>> I have change the release blocker flag for issues
>>> https://issues.apache.org/ooo/show_bug.cgi?id=118366
>>>
>>> I think it's a normal issue that we should fix but it is no show stopper
>>> issue from my point of view.
>>>
>>
>> They are claiming it is a regression compared to 3.3.0.  Also claiming
>> it is a bug in LO as well.  So probably a bug introduced in 3.4 beta?
>
>
> sure but it is a new issue caused by some other underlying changes. And as
> far as I understand it still works but is slower only.
>

Maybe I am misreading the bug report, but I don't think he is saying
that the function is slow.  I think he is saying that the
XTextRange.getString() function returns the wrong value if called
immediately, but if he introduces a delay, via a loop, then the
XTextRange.getString() function returns the correct value.

That sounds like some sort of race condition or other synchronization
issue. It could cause existing scripts to break.

-Rob

> We can definitely focus on this issue when we have time but for me it is no
> critical show stopper.
>
> Juergen

Mime
View raw message