incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Weir <robw...@apache.org>
Subject Re: [EXTENSIONS][RELEASE] (was RE: Calling all volunteers: It is time to test)
Date Mon, 05 Mar 2012 19:52:55 GMT
On Mon, Mar 5, 2012 at 1:30 PM, Larry Gusaas <larry.gusaas@gmail.com> wrote:
> On 2012-03-05 12:08 PM  Rob Weir wrote:
>>
>> On Mon, Mar 5, 2012 at 12:29 PM, Dennis E. Hamilton
>> <dennis.hamilton@acm.org>  wrote:
>>>
>>> If there is no solution for extensions, Apache OpenOffice 3.4 early
>>> incubator releases should not overload prior versions of OO.o.  I recommend
>>> that AOO 3.4 install in its own locations and not do anything that would
>>> prevent side-by-side functioning.  (My recommendation would be that it do
>>> that anyhow.  But with known breaking of an important down-level feature,
>>> that becomes imperative.)
>>>
>> In general, it is important for OOo 3.3 and earlier installs on
>> desktops to go away. Old releases increasingly become security
>> hazards, especially if they are no longer being actively maintained.
>> We do a great service to the community in general if we overwrite them
>> with the AOO 3.4.  This is true even given the inconvenience the user
>> experiences from the need to reinstall extensions.
>
>
> Users need to be informed that they will need to reinstall extensions if AOO
> 3.4 overwrites OOo3.x.x
>

Yes.  But note that this will also be true if we installed AOO into a
different directory.  They would need to reinstall all the extensions
again also.

> One option would be to not use the same user profile as OOo 3.x.x and create
> a new profile for AOO 3.4. Or do as LibreOffice did when it came out and
> import the data that can be used from the OOo user profile into a new
> profile.
>

That won't help in this case.  Regardless of where the profile is
stored, we're unable to read the local DB that stored information
about what extensions were installed.  So whether we use the same
profile or not, the user still must reinstall extensions if they want
them to work in AOO 3.4.

>
>> In any case, I think the overwrite is fine.  It is what OOo 3.3 and
>> OOo 3.2 did as well by default.  We can document in the install
>> intructions how this can be overridden.
>
>
> The warning would have to be on the download page before the download link.
> How many current users of OOo actually read the install instructions before
> installing a new version?
>

If the user's goal is to continue running OOo 3.3.0, then what can we
say?  Don't install AOO 3.4 or 4.0, or 5.0, etc.    But if they do
want to run AOO 3.4 then they will need to reinstall the extensions.
I haven't heard anyone suggest an alternative approach to solving that
problem.  Of course, "patches are welcome".

>
>>> I think there should be OOo-dev releases only until this is handled as
>>> well.  It is now clear that integration has problems and there is no reason
>>> to provoke more of it.
>
> Agree
>
> --
> _________________________________
>
> Larry I. Gusaas
> Moose Jaw, Saskatchewan Canada
> Website: http://larry-gusaas.com
> "An artist is never ahead of his time but most people are far behind
> theirs." - Edgard Varese
>
>

Mime
View raw message