incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <jogischm...@googlemail.com>
Subject Re: [RELEASE]: Bug 118914 - Upgrade package missing
Date Tue, 13 Mar 2012 07:29:28 GMT
On 3/13/12 4:33 AM, xia zhao wrote:
> Hi Ariel,
>
> I reported that problem, yes, the upgrade package is used for old OOo to
> upgrade linux package.
>
> Now it is missing in AOO 3.4 linux package.
>
> My concerns are:
> 1. "AOO 3.4 is the first release" for AOO project, we can statement it, but
> I don't think OOo users would buy in it.
>      As one old OOo user, I prefer upgrade to AOO 3.4 directly.
> 2. Even we say AOO 3.4 i the first release, the easy upgrade mechanism
> should be provided now for further AOO release.
>
> There is several linux packages, now I can upgrade from OOo 3.3.0 to AOO
> 3.4 directly by upgrade package one by one. With "upgrade" shell scripts
> offered in old OOo, I can upgrade my linux package easily. And I hope this
> issue can be resolved in AOO 3.4.

ah I now understand better what this upgrade package was and yes I agree 
that it would be nice to have but I think still not critical. Maybe some 
experienced Linux developers can work on such a meta package to install 
all other packages.

I am not so familiar with the rpm and deb packing. But it sounds not so 
difficult to provide a meta package with dependencies to all other 
packages ... Well if understand it correct.

Any volunteers?

Juergen

>
> Thanks.
>
> Lily
>
> 2012/3/9 Ariel Constenla-Haile<arielch@apache.org>
>
>> HI Jürgen,
>>
>> On Thu, Mar 08, 2012 at 05:47:01PM +0100, Jürgen Schmidt wrote:
>>> I have to confess that I don't have any clue what to do with this issue
>> [1].
>>>
>>> We have a target in instset_native/util to build a "updatepack" but
>>> it breaks on my Linux system when it tries to build a Germany
>>> language pack. But I have no language selected and it should build
>>> en-US only.
>>>
>>> Do we really have problems with an upgrade on Linux systems?
>>>
>>> I tend to mark it as non critical. Any opinions?
>>>
>>> [1] https://issues.apache.org/ooo/show_bug.cgi?id=118914
>>
>> I'm not sure what the original reporter is talking about.
>>
>> "In previous OO release, for example, OO 3.3, this is "update" package
>> under root package." seems to point to the update shell script.
>>
>> If so, this is trunk/main/setup_native/scripts/update.sh delivered as
>> update to the solver. But I couldn't find any line on scp2 including
>> this shell script in the install set.
>>
>>
>> Regards
>> --
>> Ariel Constenla-Haile
>> La Plata, Argentina
>>
>


Mime
View raw message