incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <jogischm...@googlemail.com>
Subject Re: WebDAV support: oo3.3 and oo3.4 are affecting each other
Date Mon, 12 Mar 2012 07:38:35 GMT
On 3/12/12 3:29 AM, lou ql wrote:
> On 9 March 2012 18:10, eric b<eric.bachard@free.fr>  wrote:
>
>> Hi,
>>
>>
>>
>> Disclaimer : the mail is not well quoted, so I'm not sure who I'm
>> answering. Apologies if ever my answer is not clear.
>>
>>
>> Le 9 mars 12 à 03:05, lou ql a écrit :
>>
>>
>>> 2. a dialog appears asking for username&password
>>> 3. enter correct username/password, then press Enter
>>> 4. the folder opened and I can see all contents
>>> 5. close it. do some other operations: copy image then
>>> paste...open/close...
>>> 6. click File->open in openoffice then insert
>>> http://9.123.153.36/webdavand click Open
>>> Nothing happened...
>>>
>>> it seems you did an intensive testing. But I can't reproduce the problems
>>> testing against a server running on Ubuntu and MacOS with clients based on
>>> OOo3.3 or AOO3.4 r1296433 on Windows 7 and MacOS.
>>>
>>> How do you run this on Mac openoffice? I cannot type into the open dialog
>>> on Mac 10.6, but can only select the local folders or the mounted folders.
>>>
>>
>>
>> To open URL directly with the Mac OS X version, you need to use the
>> OpenOffice.org Open dialog box (not the Apple native one).
>>
>> To achieve that, you'll have to open the preferences ( Apple + " , " key)
>> or Tools ->Options. Once done, in OpenOffice.org ->  General ->  check the
>> OpenOffice.org dialog box.
>>
>> Then quit AOOo, and try to Open a file ->  URL will be allowed (but you'll
>> lose the native box).
>>
>> See:  http://ftp.educoo.org/home/**ApacheOpenOffice.org/open_URL/**
>> AOOo_open_fr.pdf<http://ftp.educoo.org/home/ApacheOpenOffice.org/open_URL/AOOo_open_fr.pdf>
>>
>> (sorry, french version  only).
>>
>> Thank you, Eric, I can do it on Mac now.
>
> I also tried this on Windows, open Tool->Options dialog, in
> OpenOffice.org->Gernal, check on use OpenOffice.org save/open dialogs,
> then, I can connect to my webdav server...This works on both the two XPs
> that I mentioned before...
>
> So, the problem is:
>
> cannot connect to the webdav server by using system's native open dialog
> but it's OK when using the openoffice open dialog.
>
> While, system's open/save dialog is used by default

yes but this is the same behaviour as before and that is expected and 
supported right now.

Seems that it work and with the fix from Oliver for https we should be 
save for now.

Juergen

>
>
>>
>>
>>
>>   The same when I want to insert an image via URL from
>>> Insert->Picture-> From File.... I attached the open dialog, can you show
me
>>> where do you type the URL? Thank you so much..
>>>
>>> and, is there anybody can help me to recover my XP?  I tried uninstall
>>> openoffice and Ooo-dev then remove the user profile and the folder in
>>> C:\Program Files, then re-install oo3.3 this morning, but it still cannot
>>> connect to the WebDAV....
>>>
>>>
>>> Ok I should say I was able to open documents (in sub-directories, with
>>> spaces or special characters in the name) edit and save the documents.
>>>
>>> Has anybody else tried to connect to a WebDAV server?
>>>
>>>
>> Yes, me. Long time ago.  We even had a patch for that, but it was refused,
>> because it could cause an issue with Calc. I don't remind the issue number
>> in IssueZilla, so you'll have to search using "webdav" keyword os something
>> similar.
>>
>>
>> HTH
>>
>> Eric
>>
>> --
>> qɔᴉɹə
>> Projet OOo4Kids : http://wiki.ooo4kids.org/**index.php/Main_Page<http://wiki.ooo4kids.org/index.php/Main_Page>
>> L'association EducOOo : http://www.educoo.org
>> Blog : http://eric.bachard.org/news
>>
>>
>>
>>
>>
>>
>


Mime
View raw message