incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <jogischm...@googlemail.com>
Subject Re: [RELEASE]: Bug 118914 - Upgrade package missing
Date Fri, 09 Mar 2012 12:48:23 GMT
On 3/9/12 1:26 PM, Ariel Constenla-Haile wrote:
> Hi Jürgen,
>
> On Fri, Mar 09, 2012 at 08:36:18AM +0100, Jürgen Schmidt wrote:
>> On 3/8/12 10:04 PM, Ariel Constenla-Haile wrote:
>>> HI Jürgen,
>>>
>>> On Thu, Mar 08, 2012 at 05:47:01PM +0100, Jürgen Schmidt wrote:
>>>> I have to confess that I don't have any clue what to do with this issue [1].
>>>>
>>>> We have a target in instset_native/util to build a "updatepack" but
>>>> it breaks on my Linux system when it tries to build a Germany
>>>> language pack. But I have no language selected and it should build
>>>> en-US only.
>>>>
>>>> Do we really have problems with an upgrade on Linux systems?
>>>>
>>>> I tend to mark it as non critical. Any opinions?
>>>>
>>>> [1] https://issues.apache.org/ooo/show_bug.cgi?id=118914
>>>
>>> I'm not sure what the original reporter is talking about.
>>>
>>> "In previous OO release, for example, OO 3.3, this is "update" package
>>> under root package." seems to point to the update shell script.
>>>
>>> If so, this is trunk/main/setup_native/scripts/update.sh delivered as
>>> update to the solver. But I couldn't find any line on scp2 including
>>> this shell script in the install set.
>>>
>>>
>> do you have recognized any problems installing aOO3.4 on Linux over
>> a 3.3. Or does anybody else have noticed any problems?
>
> Well, things are rather distro-specific.
> I would suggest not to update, but to remove first OOo and then install
> AOO. On the other hand, it is rather likely that some package conflicts
> with libreoffice, so installing AOO will need some manual tweaking.
>
> On Fedora, for example, there was the issue with the URE package
> http://openoffice.org/projects/www/lists/users/archive/2010-11/message/581
>
> Now AOO URE package is obsoleted by libreoffice's package:
>
>
> Examining openoffice.org-ure-3.4.0-9587.x86_64.rpm:
> openoffice.org-ure-3.4.0-9587.x86_64
> Cannot install package openoffice.org-ure-3.4.0-9587.x86_64. It is
> obsoleted by installed package 1:libreoffice-ure-3.4.5.2-5.fc16.x86_64
>
> So you have to edit yum.conf
>
> su -c 'vim /etc/yum.conf'
>
> and exclude libreoffice:
>
> exclude=libreoffice*
>
>
> Some kind of conflict also exists in Ubuntu, and I guess many other
> distros.

probably yes :-(

>
> Back to the update shell script, I downloaded
> OOo_3.2.1_Linux_x86-64_install-rpm-wJRE_en-US.tar.gz and tried that
> script. At least on Fedora is completely broken, it does nothing. And as
> installing in Linux will for sure need some manual tweaking, it is not
> worth wasting the time trying to bring that script back in AOO.

I agree we should not spent too much time on this

Juergen

Mime
View raw message