incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Rist <andrew.r...@oracle.com>
Subject [BUILD] setting gcc g++ version
Date Fri, 02 Mar 2012 00:34:45 GMT
in an attempt to set the specific version of gcc on the machine used by 
the build, we tried the following:

    bash -ci 'CC=/usr/bin/gcc-4.4
      CXX=/usr/bin/g++-4.4
      ./configure --with-jdk-home=/usr/lib/jvm/java-6-openjdk --with-epm-url=http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz
--with-dmake-url=http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2 --with-lang="es
de fr it pt-BR ja zh-CN" --enable-verbose --enable-category-b --enable-minimizer --enable-presenter-console
--enable-wiki-publisher --enable-opengl --enable-dbus --enable-gstreamer --with-package-format="installed
deb" --with-build-version="2012-03-01_23:49:54-Rev.1295998"'

which was not successful as seen here:
http://ci.apache.org/builders/openoffice-linux32-nightly/builds/41/steps/shell/logs/stdio

        checking for gcc... /usr/bin/gcc
        checking the GNU gcc compiler version... checked (gcc 4.6.1)

        checking the GNU C++ compiler version... checked (g++ 4.6.1)
        checking for g++ include path... /usr/include/c++/4.6

        The variable GXX_INCLUDE_PATH  is set to: /usr/include/c++/4.6


    Am I just missing 'export' or is it even possible to use gcc/g++
    that are not in the path (not in /usr/bin)?



Mime
View raw message