incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Rist <andrew.r...@oracle.com>
Subject Re: [BUILD] Linux32 just about there - HELP
Date Thu, 01 Mar 2012 22:13:50 GMT


On 3/1/2012 12:51 PM, Herbert Duerr wrote:
> On 02/29/2012 11:20 PM, Andrew Rist wrote:
>> anyone?
>
> > ... starting unpatched epm ...
> > [...]
> > **************************************************
> > ERROR: ERROR: "/usr/bin/epm -f rpm  ooobasis3.4-core03
> > 
> /home/buildslave20/slave20/openoffice-linux32-nightly/build/main/instsetoo_native/unxlngi6.pro/OpenOffice/rpm/listfile/en-US/epm_gid_Module_Root_Files_3.lst

> --output-dir RPMS -v2  2>&1 |"!
> > in function: call_epm
> > **************************************************
>
> It could help to use a patched epm-3.7 by providing the configure 
> options:
> --with-epm-url=http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz
> --with-epm=internal
Actually - that is what we are doing - the config command is this:

    ./configure --with-jdk-home=/usr/lib/jvm/java-6-openjdk
    --with-epm-url=http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz
    --with-dmake-url=http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2
    --with-lang="es de fr it pt-BR ja zh-CN" --enable-verbose
    --enable-category-b --enable-minimizer --enable-presenter-console
    --enable-wiki-publisher --enable-opengl --enable-dbus
    --enable-gstreamer --with-package-format="installed rpm deb"
    --with-build-version="%s-Rev.%s"', "today", "got_revision"

>
> If this works then I'd suggest to copy the patched epm somewhere and 
> just provide the configure option
> --with-epm=/<somewhere>/epm
>
> Herbert

-- 

Andrew Rist | Interoperability Architect
OracleCorporate Architecture Group
Redwood Shores, CA | 650.506.9847


Mime
View raw message