incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver-Rainer Wittmann <orwittm...@googlemail.com>
Subject Re: report builder extension: cannot be installed into r1293550 on XP, win7 64-bit or Ubuntu
Date Thu, 01 Mar 2012 08:57:52 GMT
Hi

On 01.03.2012 04:42, lou ql wrote:
> On 1 March 2012 03:49, drew jensen<drewjensen.inbox@gmail.com>  wrote:
>
>> On Wed, 2012-02-29 at 09:18 -0500, Rob Weir wrote:
>>> As we approach the first Release Candidate for Apache OpenOffice 3.4,
>>> it would be wonderful if we could have some more volunteers testing
>>> the latest dev snapshots builds. Following is some information on what
>>> this requires, and how you can help.
>>>
>>> First, if you have never tested a pre-release product before, know
>>> that bugs are expected. That is the purpose of testing, to find bugs
>>> so they can be fixed. Bugs could range from UI glitches, to incorrect
>>> formatting to crashes or even data corruption.  So you probably don't
>>> want to use a test build for mission-critical tasks. Of course, I
>>> assume you have already backed up your important documents.  You do
>>> have backups, right?  Ideally you can do your testing on a separate
>>> machine from your main work machine, so if something goes wrong you
>>> will not interfere with your other work.
>>>
>>> The above are all sensible precautions when testing any pre-release
>>> software product.
>>>
>>> If you are ready to test, you can download the latest developer
>>> snapshot build from this page:
>>>
>>>
>> https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+3.4+Unofficial+Developer+Snapshots
>>>
>>> We could use help verifying the install in all real-world scenarios,
>>> on clean OS installs, as upgrades to previous versions of OOo and as
>>> installs on machines where LibreOffice or Symphony are already
>>> installed.
>>
>> Installed on Ubuntu 11.04 alongside LibO 3.5 (64bit), OpenJDK 1.6 - no
>> problems.
>>
>> Installed a few extensions - mixed results
>> - Report Builder - install good, a couple of quick reports, good.
>>
>
> I installed it to the ooo-dev r1291124 successfully on XP.  But today when
> I try to install into r1293550, there always be a message "Could not create
> java implementation loader", I tried on XP, win7 64-bit and Ubuntu, by
> using the build which provides full normal install sets...
>
> In IP_clearance page (
> https://cwiki.apache.org/confluence/display/OOOUSERS/IP_Clearance) I notice
> that several libararies are removed which are used by report builder
> extension, should this extension still be usable without those libararies?
> What's the impact of the removing?
>

The report builder extension was and is more or less a separated component in 
our project. The source code for this extension is directly located inside our 
main source code repository. The libraries which have been removed and on which 
this extension is relying on had to be removed due to their licenses.
This only means that this extension can only be build inside our project, if you 
install these libraries on your own on your system and use the corresponding 
configure options for these libraries.
The extension itself - provided in an extension repository or copied from a 
friend or ... - should be working, but as far as I know it is also relying on Java.

Best regards, Oliver.

Mime
View raw message