incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis E. Hamilton" <dennis.hamil...@acm.org>
Subject [EXTENSIONS][RELEASE] (was RE: Calling all volunteers: It is time to test)
Date Mon, 05 Mar 2012 17:29:43 GMT
If there is no solution for extensions, Apache OpenOffice 3.4 early incubator releases should
not overload prior versions of OO.o.  I recommend that AOO 3.4 install in its own locations
and not do anything that would prevent side-by-side functioning.  (My recommendation would
be that it do that anyhow.  But with known breaking of an important down-level feature, that
becomes imperative.)

I think there should be OOo-dev releases only until this is handled as well.  It is now clear
that integration has problems and there is no reason to provoke more of it.

I also suspect that it is not a good idea to rebrand the Extensions and Templates pages at
SourceForge quite so strongly, since the only extensions that are there now are for OO.o (and
perhaps LibreOffice).

 - Dennis

-----Original Message-----
From: J├╝rgen Schmidt [mailto:jogischmidt@googlemail.com] 
Sent: Monday, March 05, 2012 02:06
To: ooo-dev@incubator.apache.org
Subject: Re: Calling all volunteers: It is time to test

On 3/2/12 6:38 PM, Larry Gusaas wrote:
> On 2012-02-29 8:18 AM Rob Weir wrote:
>> Once you have installed, launch OpenOffice and look at the Help/About
>> box. If the revision shown there matches the build you installed
>> (e..g, "r1293550") then the install was a success. Please send a short
>> note to theooo-dev@incubator.apache.org telling us what platform and
>> scenario you installed (fresh install, upgrade, install next to
>> LibreOffice, etc.). This will help us understand what scenarios have
>> already been attempted and which have not.
>
> Using MacBook with OS X version 10.6.8
>
> Downloaded OOo_3.4.0_MacOS_x86_install_en-US.dmg
> Successfully installed replacing installation of OOo 3.3
>
> Installation deleted all of the extensions in my user profile. Quit OOo
> and replaced extension folder in my profile from my backup copy.
> Restarted OOo 3.4 and extensions deleted again. Will try installed
> individual extensions later today.

Hi Larry,

unfortunately extensions get lost because of the dropped Berkeley DB 
which was used to manage installed extensions. We haven't found a simple 
solution to migrate it. This will be documented in the release notes.

Sorry

Juergen


>
> All .odt files I opened worked. Was able to work with and save in
> Writer. The one database I have works. Will do further testing later.
>


Mime
View raw message