incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zhangjf <zhan...@apache.org>
Subject Re: build break on comphelper module with error message "No target registered" on Windows cygwin
Date Tue, 14 Feb 2012 01:04:47 GMT
Thanks.

My code was checked out on Mac platform and copied to Windows, so I
assume there is no file format problem on Windows Cygwin. I also
didn't make any change on the code.

I am sure I am using the gnu make 3.8.1 from cygwin.

I will reinstall a new cygwin to see if it helps.

regards,
zhangjf

On Tue, Feb 14, 2012 at 2:18 AM, Andrew Rist <andrew.rist@oracle.com> wrote:
>
>
> On 2/13/2012 7:38 AM, zhangjf wrote:
>>
>> Hi,
>>
>> I just updated the latest 3.4 code base and try to make a clean build.
>>  With the same piece of source code, it get successful on Mac
>> platform.  While on Windows under cygwin environment, when compiling
>> comphelper module, it always complains
>> "..../comphelper//Module_comphelper.mk:26: *** No target registered
>> while reading /cygdrive/f/aoo34/comphelper/Library_comphelp.mk!.
>> Stop."
>>
>> Is there any one can give some idea on how to determine this problem?
>> I failed to understand what's wrong it is getting.
>
> It is important to use make version 3.8.1 inside cygwin.  If you just select
> make it will give you 3.8.2 and it will not work.
> Inside cygwin setup you can select between these two versions.  I think this
> might be your problem.
> Also, do make sure you use cygwin to check out the files.  Otherwise, the
> files will have windows style line endings, and the compile will break.
>
> A.
>>
>>
>> regards,
>> zhang jian fang
>
>

Mime
View raw message