incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver-Rainer Wittmann <orwittm...@googlemail.com>
Subject Re: AW: Unable to install AOO on a clean Windows XP
Date Wed, 29 Feb 2012 15:55:54 GMT
Hi,

On 29.02.2012 15:56, Hans Zybura wrote:
>> Von: Ariel Constenla-Haile
>> Gesendet: Mittwoch, 29. Februar 2012 11:19
>> On Wed, Feb 29, 2012 at 08:50:31AM +0100, J├╝rgen Schmidt wrote:
>>> On 2/28/12 8:30 PM, Hans Zybura wrote:
>>>> Like Oliver, I tried the same file now
>>>>
>>>> http://people.apache.org/~orw/DevSnapshots-
>> Rev.1293550/win32/OOo_3.4.
>>>> 0_Win_x
>>>> 86_install_en-US.exe
>>>>
>>>> on a clean English win xp professional sp3 vm and I'm still getting
>>>>
>>>> "Error: An error occurred during registration of extensions!" at the
>>>> end of the installation process.
>>>>
>>>> Both with installation option "install for all users" and "only for
> me".
>>>>
>>>> With the error message still open, i.e. installation not rolled back
>>>> yet, there are no files in standard path
>>>>
>>>> C:\Program Files\OpenOffice.org 3\share\extensions
>>>>
>>>> except for "package.txt"
>>>
>>> It is really strange, I had the chance to install it on a Win XP box
>>> with SP3 and where no office was installed before.
>>>
>>> Everything works as expected ...
>>>
>>> We need somebody with Win XP and a debugger and who is able to create
>>> at least a stacktrace
>>
>> not that I'm taking the task here (I'm not building on Win right now), but
> I
>> wonder how do you debug this? Do you have to attach the msiexec, the
>> installer, ...?
>>
>> Google found some pointers:
>> http://support.microsoft.com/kb/223300
>> http://blogs.msdn.com/b/piyush/archive/2007/04/29/debugging-windows-
>> installer-msi-using-visual-studio-2005.aspx
>> http://blogs.msdn.com/b/windows_installer_team/archive/2005/09/21/471
>> 793.aspx
>
> 1. I created an msi log file on the clean winxp sp3 vm, where the problem
> exists. I will send it via personal email if someone asks for it. And of
> course I can do it again, if need be.
>
> The last 3 lines before the error is thrown are:
>
> [HZ_1:] MSI (s) (44:04) [13:02:50:677]: Executing op:
> ActionStart(Name=RegisterExtensions,,)
> [HZ_2:] Action 13:02:50: RegisterExtensions.
> [HZ_3:] MSI (s) (44:04) [13:02:50:677]: Executing op:
> CustomActionSchedule(Action=RegisterExtensions,ActionType=1025,Source=Binary
> Data,Target=RegisterExtensions,CustomActionData=C:\Program
> Files\OpenOffice.org 3\)
>
> 2. In the log file, I noticed the following lines:
> Property(C): REQUIRED_DOTNET_VERSION = 2.0.0.0
> Property(C): DOTNET_SUFFICIENT = 0
>
> I took that as a hint and installed .Net Framework 2.0. This did NOT solve
> the problem, though.
>
> Side note: If .NET 2.0 really is required, than you should keep in mind,
> that .Net is not originally part of Win XP, any Service Pack, or standard
> security update. So it should either be part of the installation packet or
> not required. Developers using Visual Studio tend to forget that, because
> .Net is part of a Visual Studio installation.
>

.NET 2.0 should not be required from my point of view.

Currently, we have a couple of installations that worked on specific clean 
Windows XP environments and a couple of installations that did not work.

BTW, do we already have an issue for this.
If not I am asking to submit one in order to have all information about this in 
one place.
This issue should be also the right place to attach a such a created msi log 
file from my point of view.

Best regards, Oliver.

Mime
View raw message