incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From J├╝rgen Schmidt <jogischm...@googlemail.com>
Subject Re: Build breaks while making 'openoffice_en-US.archive'
Date Mon, 20 Feb 2012 17:01:28 GMT
On 2/20/12 5:50 PM, Andrew Rist wrote:
> On 2/19/2012 3:22 PM, Ariel Constenla-Haile wrote:
>> Hi Regina,
>>
>> On Sun, Feb 19, 2012 at 11:51:10PM +0100, Regina Henschel wrote:
>>> I've copied those files to external\msvcp90 and made a clean build.
>>> But it breaks again with error message
>>> ERROR: ERROR: unopkg.exe sync --verbose
>>> -env:UNO_JAVA_JFW_ENV_JREHOME=true 2>&1 | failed!
>>> in function: register_extensions
>>> and the already cited text in log_OOO340_en-US.log
>>>
>>> Searching with google I found that others, not connected to
>>> openoffice and using MSVC directly, have similar problems when
>>> making a debug build. The advise in those cases was to turn off
>>> "incremental linking". But I have now knowledge of this.
>> yes, I've found this too.
>> According to MSDN docs
>> http://msdn.microsoft.com/en-us/library/4khtbfyf%28v=vs.90%29.aspx
>> the command is /INCREMENTAL:YES|NO
>> Searching in solenv/inc and solenv/gbuild/platform it seems it is already
>> set to NO in some places. I doubt this is the root cause of the problem
>> here, the error also happens now on the build boot:
>>
>> http://ci.apache.org/builders/aoo-win7/builds/58
>> http://ci.apache.org/builders/aoo-win7/builds/59
>>
>>
>> @Andrew: do you have access to the buildboot machine? The log does not
>> help much in instsetoo_native/wntmsci12.pro/misc/logs:
>> http://ci.apache.org/projects/openoffice/buildlogs/win/main/instsetoo_native/wntmsci12.pro/misc/logs/util.txt
>>
>>
>> It would be helpful to also have all the logs in the logging folders: in
>> this case
>>
>> C:/Users/buildslave14/slave14/aoo-win7/build/main/instsetoo_native/wntmsci12.pro/OpenOffice/archive/logging/en-US/log_OOO340_en-US.log
>>
> people.apache.org/~arist/log_OOO340_en-US.log
>>
>> They follow the pattern:
>> instsetoo_native/$INPATH/$TARGET/$PKGFORMAT/logging/$LANG/log_OOO340_$LANG.log
>>
>> instsetoo_native/$INPATH/$TARGET/$PKGFORMAT/logging/$LANG/fileinfo_$TARGET.log
>>
>>
>>
>>> My non-pro build was successful in January with revision 1232793.
>>>
>>> Any further ideas?
>> No, sorry. We'll have to wait until tomorrow some of the guys building
>> in Windows can take a look.
>> It looks like something got broken recently: IIRC the build boot *did*
>> some successful builds.
> we did - this was the error that broke the build

update to revision 1291365, that shoudl fix the build breaker on Windows

Oliver have figured out that a wrong deliver overrides unopkg.exe ...

Juergen

>>
>>
>> Regards
>


Mime
View raw message