incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl Marcum <cmar...@apache.org>
Subject Re: [code] (stax-api) Anyone still uses Java 5?
Date Sun, 12 Feb 2012 13:55:37 GMT
On 02/11/2012 10:23 PM, Pedro Giffuni wrote:
> Hi;
>
> We currently carry an old version(1.0) of StAX-api that is
> under copyleft. This library is supposed to be needed by
> Saxon-B but we don't really use this library because
> is now part of OpenJDK 1.6 and upper so we only need it
> when trying to use an old version of Java and we are not
> using the system-saxon.
>
> The latest version of this library (1.2) is now under
> Apache License 2:
>
> http://stax.codehaus.org/
>
> I started to update it but I can't really test it:
> deinstalling jdk6 to bring back jdk5 and rebuild
> everything is not exactly fun ;).
>
> Anyone wants to play a bit with a patch? Alternatively
> we could just leave things as they are and drop
> StaX out of the distribution after 3.4-Release.
>
> Pedro.
>
>

+1 on dropping Java 5.

The only reason I could see to keep Java 5 would be to not break users 
programs or a due to a platform we wish to support that could not use 
Java 6.

I checked Oracle's compatibility page for Java SE 5 to 6 [1] and 
virtually all programs that were built on 5 will run on 6.

I am even running Java 6 on a Win 2000 instance I keep for testing.
Supported platforms for Java 6 [2].

[1] http://www.oracle.com/technetwork/java/javase/compatibility-137541.html

[2] 
http://www.oracle.com/technetwork/java/javase/system-configurations-135212.html

Best regards,
Carl

Mime
View raw message