incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: Build breaks while making 'openoffice_en-US.archive'
Date Sun, 19 Feb 2012 16:35:35 GMT
Hi Regina,

On Sun, Feb 19, 2012 at 03:20:24PM +0100, Regina Henschel wrote:
> Hi all,
> 
> next problem :(
> 
> It compiles all fine but breaks in the packing step, error message below.
> I'm using MSVC 2008 express on WinXP.
> 
> Kind regards
> Regina
> 
> ######################################################
> Registering extensions:
> ######################################################
> Current dir:
> /tmp/nTYSz4FuLR/OOo_3.4.0_Win_x86_install-arc_en-US/OpenOffice.org
> 3/program
> Systemcall: unopkg.exe sync --verbose
> -env:UNO_JAVA_JFW_ENV_JREHOME=true 2>&1 |
> /tmp/nTYSz4FuLR/OOo_3.4.0_Win_x86_install-arc_en-US/OpenOffice.org
> 3/program/unopkg.exe: error while loading shared libraries:
> MSVCR90D.dll: cannot open shared object file: No such file or
> directory

you are doing a NON-pro build, and it seems it requires MSVCR90D.dll to be
found by the linker.

Try copying this dll in trunk\main\external\msvcp90

Searching in google tells you can find that library on 
%PROGDIR%\Microsoft Visual Studio 9.0\VC\redist\Debug_NonRedist\x86\Microsoft.VC90.DebugCRT
(not sure if this comes with the Express Edition), or even online.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message