incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: Fwd: buildbot success in ASF Buildbot on aoo-win7
Date Wed, 08 Feb 2012 19:00:34 GMT
Hi Andrew,

On Wed, Feb 08, 2012 at 09:48:57AM -0800, Andrew Rist wrote:
> It is true, we now have a Windows buildbot.  The results of the
> latest run are posted - here are the relevant links:
> 
>  * buildbot output - http://ci.apache.org/builders/aoo-win7/builds/35
>  * html log page -
>    http://ci.apache.org/projects/openoffice/buildlogs/win/log/wntmsci12.pro.build.html
>  * windows install bits -
>    http://ci.apache.org/projects/openoffice/install/win/
> 
> This would be an opportune time to review the build settings.  Here
> is what the bb is running - comments and changes requested...
> 
>    svn co http://svn.apache.org/repos/asf/incubator/ooo/trunk build
> 
>    svnversion build


this isn't really necessary, the build boot is on Windows, so just build
it.

>    wget -O external/unowinreg/unowinreg.dll
>    http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dl

ATL and ActiveX should not be disabled.
This way important features for Windows users (normal users and API
users) are disabled (OLE embedding and OLE automation).
Is the build boot building with the Visula Studio 2008 Express Edition?

>    --disable-atl
>    --disable-activex


AFAIK if you disable ODK, there won't be an SDK built. Windows API users
may want to try the SDK.

>    --disable-odk


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message