incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: [BUILD]solaris build failed again.
Date Wed, 01 Feb 2012 23:33:20 GMT
On Wed, Feb 01, 2012 at 06:29:49PM -0300, Ariel Constenla-Haile wrote:
> > > > GTK_CFLAGS="-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk
> > > > -1.0 -I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include
-I/usr/s
> > > > fw/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
 "
> > > > GTK_LIBS="-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoxft-1.0 -lpangox-1.0
-lpa
> > > > ngo-1.0 -lgdk_pixbuf_xlib-2.0 -lgdk_pixbuf-2.0 -lm -lmlib -lgobject-2.0
-lgmodul
> > > > e-2.0 -lglib-2.0  "
> > > > GTHREAD_CFLAGS="-mt -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
 "
> > > > GTHREAD_LIBS="-mt -lgthread-2.0 -lglib-2.0  "
> > 
> > We had the same problem building AOO on OpenSolaris. It seems, that
> > adding "-lgthread-2.0 -lpthread -lthread" to GTK_LIBS fixed this problem
> > in our setup (maybe "-lgthread-2.0" is enough).
> > However this does not seem to be the "right" solution ;)
> 
> you were in the right way to the solution. Rev. 1230097
> http://svn.apache.org/viewvc/incubator/ooo/trunk/main/vcl/Library_vclplug_gtk.mk?r1=1229815&r2=1230097&diff_format=h
> accidentally removed GTHREAD_LIBS
 

for the record, the build didn't break on Linux/Ubuntu because GTK_LIBS
includes GTHREAD_LIBS:

GTK_LIBS="-pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0
-lcairo -lpango-1.0 -lfreetype -lfontconfig -lgdk_pixbuf_xlib-2.0 -lgmodule-2.0 -lgdk_pixbuf-2.0
-lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0  "

GTHREAD_LIBS="-pthread -lgthread-2.0 -lrt -lglib-2.0  "

all libraries listed in GTHREAD_LIBS are already present in GTK_LIBS;
but this is not the case on Solaris.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message