incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pedro Giffuni <...@apache.org>
Subject [code] (stax-api) Anyone still uses Java 5?
Date Sun, 12 Feb 2012 03:23:43 GMT
Hi;

We currently carry an old version(1.0) of StAX-api that is
under copyleft. This library is supposed to be needed by
Saxon-B but we don't really use this library because
is now part of OpenJDK 1.6 and upper so we only need it
when trying to use an old version of Java and we are not
using the system-saxon. 

The latest version of this library (1.2) is now under
Apache License 2:

http://stax.codehaus.org/

I started to update it but I can't really test it:
deinstalling jdk6 to bring back jdk5 and rebuild
everything is not exactly fun ;).

Anyone wants to play a bit with a patch? Alternatively
we could just leave things as they are and drop
StaX out of the distribution after 3.4-Release.

Pedro.


Mime
View raw message