incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Christener <li...@0x17.ch>
Subject Re: [BUILD]solaris build failed again.
Date Wed, 01 Feb 2012 19:01:06 GMT
Hi,

On Tue, 2012-01-17 at 07:41 -0300, Ariel Constenla-Haile wrote:
> Hi L'oiseau de mer,
> 
> On Mon, Jan 16, 2012 at 09:29:33AM +0800, L'oiseau de mer wrote:
> > This is my content in SolarisX86Env.Set.sh:
> > 
> > GTK_CFLAGS="-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk
> > -1.0 -I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include -I/usr/s
> > fw/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  "
> > GTK_LIBS="-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoxft-1.0 -lpangox-1.0 -lpa
> > ngo-1.0 -lgdk_pixbuf_xlib-2.0 -lgdk_pixbuf-2.0 -lm -lmlib -lgobject-2.0 -lgmodul
> > e-2.0 -lglib-2.0  "
> > GTHREAD_CFLAGS="-mt -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  "
> > GTHREAD_LIBS="-mt -lgthread-2.0 -lglib-2.0  "

We had the same problem building AOO on OpenSolaris. It seems, that
adding "-lgthread-2.0 -lpthread -lthread" to GTK_LIBS fixed this problem
in our setup (maybe "-lgthread-2.0" is enough).
However this does not seem to be the "right" solution ;)
Could someone who knows the build system a bit better take a look at
this?

I have some other build related "fixes" (or workarounds) for AOO on
Solaris/SPARC. Is someone interested to look at them?
In the end I got a working build on that platform - so if someone is
interested in this, I'd be glad to share the stuff I found out.

kind regards
Nicolas


Mime
View raw message