incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 杨继超 <jcyan...@gmail.com>
Subject Re: LIBWPG error while compiling in cygwin
Date Sun, 29 Jan 2012 19:22:47 GMT
I followed the wiki article "build on windows",
./configure \
  --disable-build-mozilla \
  --disable-mozilla \
  --disable-activex \
  --disable-directx \
  --disable-atl \
  --without-junit \
  --disable-binfilter \
  --disable-odk \
  --with-cl-home="/cygdrive/d/Program Files/Microsoft Visual Studio 9.0/VC"
\
  --with-mspdb-path="/cygdrive/d/Program Files/Microsoft Visual Studio
9.0/Common7/IDE" \
  --with-frame-home="/cygdrive/d/Program Files/Microsoft SDKs/Windows/v6.1"
\
  --with-psdk-home="/cygdrive/d/Program Files/Microsoft SDKs/Windows/v6.1" \
  --with-midl-path="/cygdrive/d/Program Files/Microsoft
SDKs/Windows/v6.1/Bin" \
  --with-asm-home="/cygdrive/d/Program Files/Microsoft Visual Studio
9.0/VC/Bin" \
  --with-csc-path="/cygdrive/c/Windows/Microsoft.NET/Framework/v4.0.30319" \
  --with-jdk-home="/cygdrive/d/Program Files/Java/jdk1.6.0_30" \
  --with-ant-home="/cygdrive/d/Program Files/Apache Software
Foundation/Apache Ant/bin"

Jichao

2012/1/30 Jürgen Schmidt <jogischmidt@googlemail.com>

> Am Sonntag, 29. Januar 2012 schrieb 杨继超 <jcyangzh@gmail.com>:
> > I got a LIB PWG error while compiling the latest svn repo in cygwin under
> > windows 7.
> >
> > checking whether to provide libstdc++/libgcc_s in the installset... yes
> > checking which zlib to use... internal
> > checking which jpeg to use... internal
> > checking which expat to use... internal
> > checking which libwpd to use... ./configure: line 12489: syntax error
> near
> > unexpected token `LIBWPD,'
> > ./configure: line 12489: `    PKG_CHECK_MODULES( LIBWPD, libwpd-0.8 )'
> >
> > please help me, thx.
> >
> Libwpd or better the word perfect filter is removed for ip clearance. There
> will be no replacement. Perhaps somebody will be interested to work on such
> filter as extension but that is something different.
>
> We build the sources frequently on Win7 without any problems. Can you tell
> us which configure switches you use exactly? Maybe there is a problem
> somewhere in a special constellation of used switches...
>
> Juergen
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message