incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Regina Henschel <rb.hensc...@t-online.de>
Subject Re: [CODE] update services
Date Fri, 27 Jan 2012 18:51:09 GMT
Hi Ariel,

Ariel Constenla-Haile schrieb:
>
> Hi Regina,
>
> On Fri, Jan 27, 2012 at 12:02:41PM +0100, Regina Henschel wrote:
>> I have tried this:
>> I have written analog to the example in the wiki page
>>
>> <?xml version="1.0" encoding="utf-8"?>
>> <inst:description
>> xmlns:inst="http://installation.openoffice.org/description">
>
> This must be the UpdateID in version.ini
>>    <inst:id>OpenOffice.org_2_de</inst:id>
>>    <inst:version>3.4</inst:version>

For me it works for OOo2.4.3 with UpdateID=OpenOffice.org_2_de and for 
OOo3.3 with UpdateID=OpenOffice.org_3_de with the same check.Update file.

>
>
> This must be ProductBuildid in version.ini
>>    <inst:buildid>340m1(Build:9584)</inst:buildid>
>
>
> The next one should be simply Windows.

Yes, you are right. I have changed it to
   <inst:buildid>9584</inst:buildid>
   <inst:os>Windows</inst:os>
and now it works with my file for me.
It enables the download-button and a click on it opens the URL which is 
in <inst:update src=... >

  Check for example
>
> ${USER_CONFIG_DIR}\OpenOffice.org\3\user\config\javasettings_Windows_x86.xml
>
> That file has the form javasettings_${_OS}_${_ARCH}.xml
> so you can get the next two items from this file name:

I didn't know where _OS and _ARCH are defined and guessed them.

>
>>    <inst:os>Windows_NT</inst:os>
>>    <inst:arch>x86</inst:arch>
>
> ${_OS}   Windows  - wrong
> ${_ARCH} x86      - ok
>
>>    <inst:update type="text/html"
>> src="http://archive.apache.org/dist/incubator/ooo/stable/" />
>> </inst:description>
>>
>> and put it as file with file name test_check.update
>> to this location
>> http://www.rhenschel.homepage.t-online.de/test_check.update
>>
>> Then I have changed UpdateURL in version.ini to point to this URL.
>> When I now let OpenOffice search for Update, I get the response,
>> that the version is up to date.
>> I have tried varying entries in nodes 'inst:id' 'inst:version' and
>> 'inst:buildid', but always get "version is up to date".
>
> try this one, it's working; in version.ini:
>
> UpdateURL=http://people.apache.org/~arielch/ProductUpdateService/check.Update.win

Yes, that works for me too.

So it seem, that 'check.Update' needs to be a script, that returns such 
a file, we have written manually now.

Kind regards
Regina


Mime
View raw message