incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer ...@a-w-f.de>
Subject Re: Some errors have crept in in the BSD build.
Date Fri, 20 Jan 2012 15:11:47 GMT
Hi,


On 20.01.2012 15:43, Pedro Giffuni wrote:
> Hi ..
>
> We had the build mostly working with some local hacks but
> lately we've seen some strange errors.
>
> This warning should be easy to fix. When running configure
> procedure:
>
> configure: WARNING: not using cppunit
> Use of uninitialized value $ENV{"TMPDIR"} in string eq at ./set_soenv line 2006.

Maybe something like:

diff --git a/main/set_soenv.in b/main/set_soenv.in
old mode 100644
new mode 100755
index 0011cce..d4d9ebf
--- a/main/set_soenv.in
+++ b/main/set_soenv.in
@@ -2003,7 +2003,7 @@ ToFile( "XAU_LIBS",          "@XAU_LIBS@", 
  "e" );
  ToFile( "GXX_INCLUDE_PATH",  PathFormat("@GXX_INCLUDE_PATH@"), "e" );
  ToFile( "COMMON_BUILD_TOOLS",$COMMON_BUILD_TOOLS,  "e" );
  if ($platform !~ m/cygwin|os2/) {
-   if ( $ENV{"TMPDIR"} eq "" ) {
+   if ( !defined $ENV{"TMPDIR"} || $ENV{"TMPDIR"} eq "" ) {
        ToFile( "TMPDIR",      "/tmp",               "e" );
     } else {
        ToFile( "TMPDIR",      "$ENV{'TMPDIR'}",     "e" );

>
> But what is really weird is that I am getting these
>
> ____
> ...
> Entering /usr/ports/editors/openoffice/work/ooo/main/cpputools/source/regsingleton
>
> Making:    all_regsingleton.dpobj
> In file included from /usr/local/include/libxml2/libxml/encoding.h:28:0,
>                   from /usr/local/include/libxml2/libxml/parser.h:807,
>                   from /usr/ports/editors/openoffice/work/ooo/main/jvmfwk/source/libxmlutil.hxx:27,
>                   from /usr/ports/editors/openoffice/work/ooo/main/jvmfwk/source/libxmlutil.cxx:26:
> /usr/local/include/iconv.h:114:3: error: 'mbstate_t' does not name a type
>
> ...
> ___________
>
> We had already analysed this as being a C++ issue with our
> version of libxml. What is strange is that this had
> disappeared when updating our gbuild configuration and is
> now back (apparently after Andre's changes).

Sorry.  I am not away of any changes I made that could influence the 
building of libxml2.
Is there anything I can do to help?

-Andre

>
> Pedro.

Mime
View raw message