incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver-Rainer Wittmann <orwittm...@googlemail.com>
Subject Re: smoketestoo_native
Date Tue, 10 Jan 2012 09:31:29 GMT
Hi,

On 09.01.2012 10:59, linyi li wrote:
> Hi Oliver,
> I tried you configure options, but the entire build can not work well.
>
> My configure options is:
>
> ./configure --with-jdk-home=/usr/lib/jvm/java-6-sun --with-system-python
> --enable-verbose --with-epm-url="
> http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz"
>
>
> I downloaded cppunit_1.12.1.orig.tar.gz and installed manually. The error
> of missing files is gone, but it stoped by the following error:
>
> /usr/bin/ld: cannot find -ltest
>
> collect2: ld returned 1 exit status
>
> dmake: Error code 1, while making './unxlngi6.pro/lib/libsmoketest.so'
>
> Then I tried to build in test module, but it prompted: "cppunit disabled.
> Nothing to do".
>
> But if I added "--with-system-cppunit" in the configure, it can not be
> built successfully.
>
>
> Do you have any idea about this?
>
>

I do not have any information about your environment, except that you are 
working on Ubuntu.

Regarding the build error it seems you are hit by the linker problem under 
Ubuntu 11.10 - have a look at thread "ld: gold vs bfd" on ooo-dev mailing list. 
Are you using Ubuntu 11.10?

Which configure options are working or not working on your environment depends 
on your system setup. Thus, my configure options along with the information 
about the system which I am using are meant to give you some hints about an 
environment which worked fine.

I am not an expert on Ubuntu. To get my AOO build running in my environment I 
was following the information given on certain threads on ooo-dev mailing list 
and in the building guide in our wiki. I also needed some try-and-error rounds 
in order to succeed.


Best regards, Oliver.

Mime
View raw message