incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reizinger Zoltán <zreizin...@hdsnet.hu>
Subject Re: Problems with SVG in Writer
Date Thu, 05 Jan 2012 16:31:58 GMT
2012.01.05. 17:06 keltezéssel, Armin Le Grand írta:
>     Hi Ariel and Regina,
>
> please write a bug report and set to me.
>
> On 05.01.2012 16:22, Reizinger Zoltán wrote:
>> Ariel 2012. 01.0 1 1226179. builded version.
>>
>> I now tested with some svg file from wikipedia, on Win7:
>>
>> http://en.wikipedia.org/wiki/File:Svg_text_flowregion_test.svg
>>
>> http://en.wikipedia.org/wiki/File:Japanese_text_test.svg
>>
>> http://en.wikipedia.org/wiki/File:Korean_text_test.svg
>>
>>
>> It has unstable behavior when inserted one into first document works
>> correctly, but all gone when I saved the file, and empty frames shows
>> errors.
>> Closing and reopening file, the svg pictures on their place.
>
> Only in Writer, or also on Draw/Impress?

I tested only in Writer, until now, when I tested in Draw and Impress.
The problems exist in Writer only, the Draw, and Impress works correctly.

>
>> In second case in new document, inserted one without problem, when
>> inserted second it shows up, but first gone, same happens with third
>> picture.
>> Saving document not change the status, reopening document solve the
>> problems.
>>
>> In Third case, the inserting went correctly, but I scrolled the page
>> down and up the pictures gone.
>>
>> May be it is a text only problem other svg files from:
>> http://croczilla.com/bits_and_pieces/svg/samples
>
> This means text in Svg? Or Writer, too?
Not, I tested Writer with only these  svg pictures files from this site:
http://croczilla.com/bits_and_pieces/svg/samples/circles1/circles1.svg
http://croczilla.com/bits_and_pieces/svg/samples/quadbezier1/quadbezier1.svg
http://croczilla.com/bits_and_pieces/svg/samples/circles1/circles1.svg

Now checked the bugzilla and 
https://issues.apache.org/ooo/show_bug.cgi?id=118338 describes similar 
problem, and the attached svg file cause same problem.

I will add above examples which cause problems, to the bug 118338, and 
set to you.

Zoltan
>
>> not cause such problem.
>>
>> This is my results.
>> Regards,
>> Zoltan
>>
>>
>>
>>
>> 2012.01.05. 14:59 keltezéssel, Regina Henschel írta:
>>> Hi,
>>>
>>> I have severe problems with svg-graphics in Writer. Is it not ready to
>>> be used in Writer?
>>> I use build from Ariel from 2011-12-24 on WinXP.
>>>
>>> Kind regards
>>> Regina
>>>
>>
>>
>
> Sincerely,
>     Armin
> -- 
> ALG
>
>


Mime
View raw message