incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver-Rainer Wittmann <orwittm...@googlemail.com>
Subject Re: smoketestoo_native
Date Wed, 04 Jan 2012 08:23:25 GMT
Hi,

On 29.12.2011 09:40, linyi li wrote:
> After finishing a build I want to do smoketest over Ubuntu. But thers is
> some problem.
>
> My step is:
>
> source LinuxX86Env.Set.sh
>
> cd smoketestoo_native&&  build
>
>
> But error occured while making smoketest.obj. The reason is that some files
> do not exist,such as cppunit/TestAssert.h,  cppunit/TestFixture.h, etc.
>
> I redid "./configure" with "--with-system-cppunit" and builded again. But
> the error is still there.
>
> I downloaded cppunit-cvs-repo-archive.tar.bz2 from internet and put the
> desired files under folder smoketestoo_native, but other errors occured. I
> think maybe I put it in a wrong directory.
>
> Doea anybody know how to fix this problem?
>

Hm.. I did not have such a problem.

I had setup an Ubuntu 11.10, 32bit in a virtual machince using VirtualBox under 
Window 7, 64bit.
My configure options are:
--with-dmake-url=http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2 
\
--with-epm-url=http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz \
--without-junit \
--with-system-cppunit \
--disable-binfilter \
--disable-odk \
--enable-category-b \
--disable-build-mozilla \
--disable-gstreamer \
--without-stlport
After a complete build a 'build' in smoketestoo_native works fine - the test was 
successful.

Do you have some more information about your environment?

Best regards, Oliver.

Mime
View raw message