incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: [BUILD]solaris build failed again.
Date Tue, 17 Jan 2012 10:41:51 GMT

Hi L'oiseau de mer,

On Mon, Jan 16, 2012 at 09:29:33AM +0800, L'oiseau de mer wrote:
> This is my content in SolarisX86Env.Set.sh:
> 
> GTK_CFLAGS="-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk
> -1.0 -I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include -I/usr/s
> fw/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  "
> GTK_LIBS="-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoxft-1.0 -lpangox-1.0 -lpa
> ngo-1.0 -lgdk_pixbuf_xlib-2.0 -lgdk_pixbuf-2.0 -lm -lmlib -lgobject-2.0 -lgmodul
> e-2.0 -lglib-2.0  "
> GTHREAD_CFLAGS="-mt -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  "
> GTHREAD_LIBS="-mt -lgthread-2.0 -lglib-2.0  "
> 
> And my GTK version is 2.4.9 , gthread is 2.4.1.

it would help to know the command generated to invoke your compiler.
If it worked before, but stopped working after the latests revision, it
might be the change in the external library.
Comparing the previous command that worked with this new one, you'll get
an idea of what's wrong now. Just a hint, as I've never built on
Solaris.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message