incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From drew <d...@baseanswers.com>
Subject Re: Java 7 and Apache OpenOffice
Date Sat, 07 Jan 2012 17:44:02 GMT
On Sat, 2012-01-07 at 12:09 -0500, Carl Marcum wrote:
> Raphael,
> 
> On 01/07/2012 07:33 AM, Raphael Bircher wrote:
> > Hi all
> >
> > Is sameone around here with Java 7? I hear that LO 3.4.x has trubble
> > with Java 7. So this is probabily also a problem at AOO 3.4. Can sameone
> > test this?
> >
> > Greetings Raphael
> 
> I installed OOo-Dev_OOO340m1_Linux_x86-64_install-rpm_en-US from 
> http://people.apache.org/~arielch/packages/
> 
> OS is Fedora 16 x86_64
> My bash_profile has:
> JAVA_HOME=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.1.x86_64
> 
> My system would normally run java 7:
>  > java -version
> java version "1.7.0_b147-icedtea"
> OpenJDK Runtime Environment (fedora-2.0.3.fc16-x86_64)
> OpenJDK 64-Bit Server VM (build 21.0-b17, mixed mode)
> 
> The AOO 3.4 java options dialog only displays the 1.6 versions which are 
> installed.
> 
> When I try to add a 1.7 jre, I receive a "The folder you selected does 
> not contain a Java runtime environment" error.
> 
> I can also confirm this is the same behavior as OOo 3.3.0 I have 
> installed by download previously.
> 
> If can be of further help, please let me know.
> 
> Best regards,
> Carl
> 

Beware third hand information!!!!

IIRC, the fix turned out to be an update to a string resource in the
code - easy hack - but that comes from reading along on a mailing list,
third hand information ;-/



Mime
View raw message