incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From linyi li <lilinyi921...@gmail.com>
Subject Re: Build AOO on Ubuntu
Date Tue, 13 Dec 2011 02:51:44 GMT
Hi all,
Finally, I build AOO 3.4 on Ubuntu successfully:)
Thanks all of you.

The following is my step:


   1. svn co https://svn.apache.org/repos/asf/incubator/ooo/trunk ooo
   2. cd ooo/main
   3. wget -O external/unowinreg/unowinreg.dll
   http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll
   4. autoconf
   5. sudo apt-get install g++ gcc bison flex libarchive-zip-perl
   libcups2-dev libpam0g-dev sun-java6-jdk gperf libfreetype6-dev libxaw7-dev
   libfontconfig1-dev libxrandr-dev patch libgconf2-dev libgnomevfs2-dev ant
   libgtk2.0-dev junit junit4
   6. sudo apt-get build-dep openoffice.org
   7. ./configure --with-jdk-home=/usr/lib/jvm/java-6-sun
   --with-system-python --enable-verbose --with -epm-url="
   http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz"
   8. ./bootstrap
   9. source LinuxX86Env.Set.sh
   10. Downloaded 18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz and
   3ade8cfe7e59ca8e65052644fed9fca4-epm-3.7.tar.gz from the internet and put
   them into ext_source/.
   11. cd instsetoo_native && build --all --html
   12. cd $SRC_ROOT/ucpp/$INPATH/misc/build/ucpp && make clean && make
   13. cp -f ucpp $SRC_ROOT/ucpp/$INPATH/bin
   14. cd $SRC_ROOT/ucpp && deliver
   15. cd instsetoo_native && build –all



2011/12/12 Tsutomu Uchino <hanya.runo@gmail.com>

> Hi,
>
> 2011/12/12 linyi li <lilinyi921734@gmail.com>:
> > Hi,
> >
> > When I built module udkapi, while compiling XBridgeTest.idl, error
> occured:
> > undefined symbol: rtl_allocateMemory.
> > Here is the error log:
> > --------------------------------//
> >
> > =============
> >
> > Building module udkapi
> >
> > =============
> >
> >
> >  Entering /home/lily/ooo/main/udkapi/com/sun/star/test/bridge
> >
> >
> >  mkout -- version: 1.8
> >
> > : && LD_LIBRARY_PATH=/home/lily/ooo/main/solver/340/
> unxlngi6.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}<http://unxlngi6.pro/lib$%7BLD_LIBRARY_PATH:+:$%7BLD_LIBRARY_PATH%7D%7D>
> > /home/lily/ooo/main/solver/340/unxlngi6.pro/bin/idlc -verbose
> > @/tmp/mkmxtPok
> >
> > /home/lily/ooo/main/solver/340/unxlngi6.pro/bin/idlc: compiling 1 source
> > files ...
> >
> > Compiling: XBridgeTest.idl
> >
> > /home/lily/ooo/main/solver/340/unxlngi6.pro/bin/ucpp: symbol lookup
> error:
> > /home/lily/ooo/main/solver/340/unxlngi6.pro/bin/ucpp: undefined symbol:
> > rtl_allocateMemory
> >
> > /home/lily/ooo/main/solver/340/unxlngi6.pro/bin/idlc: preprocessing file
> > /home/lily/ooo/main/udkapi/com/sun/star/test/bridge/XBridgeTest.idl
> failed
> >
> > dmake: Error code 127, while making '../../../../../
> > unxlngi6.pro/ucr/cssbridgetest.db'
> >
> >
> >  1 module(s):
> >
> > udkapi
> >
> > need(s) to be rebuilt
> >
> >
> >  Reason(s):
> >
> >
> >  ERROR: error 65280 occurred while making
> > /home/lily/ooo/main/udkapi/com/sun/star/test/bridge
> > -------------------------//
> > Does anybody know how to fix it?
> >
> >
> > 2011/12/12 linyi li <lilinyi921734@gmail.com>
> >
> >> Hi Tsutomu,
> >>
> >> I have already put that file into ext_source/ directory.
> >> I tried to build again and the last error disappeared.
> >> Thank you very much:)
> >>
> >> Hope the following build successful:)
> >>
> >>
> >>
> >> 2011/12/12 Tsutomu Uchino <hanya.runo@gmail.com>
> >>
> >>> Hi,
> >>>
> >>> 2011/12/12 linyi li <lilinyi921734@gmail.com>:
> >>> > Hi, Andrew
> >>> [snip]
> >>> >
> >>> > ---------------------------------------------
> >>> >
> >>> > Entering /home/lily/ooo/main/stlport
> >>> >
> >>> >  mkout -- version: 1.8
> >>> >
> >>> > dmake: Error: -- `./
> >>> >
> unxlngi6.pro/misc/18f577b374d60b3c760a3a3350407632-STLport-4.5.unpack'
> >>> not
> >>> > found, and can't be made
> >>> >
> >>> >  1 module(s):
> >>> >
> >>> > stlport
> >>> >
> >>> > need(s) to be rebuilt
> >>> >
> >>> >  Reason(s):
> >>> >
> >>> >  ERROR: error 65280 occurred while making /home/lily/ooo/main/stlport
> >>> >
> >>> > --------------------------
> >>> >
> >>> > Does anybody know where the `./
> >>> >
> unxlngi6.pro/misc/18f577b374d60b3c760a3a3350407632-STLport-4.5.unpack'
> >>>  is?
> >>> >
> >>> >
> >>> > Thanks a lot.
> >>>
> >>> There were three STLport files in older repository but current
> >>> repository has two of them.
> >>> Get the following file and put it into ext_source/ directory:
> >>>
> >>>
> http://hg.services.openoffice.org/binaries/18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz
> >>>
> >>> Regards,
> >>> Tsutomu
> >>>
> >>
> >>
> I met the same problem on ucpp and I thought it was occurred only on
> my environment. ucpp can be compiled individually, so try as follows:
>
> cd $SRC_ROOT/ucpp/$INPATH/misc/build/ucpp && make clean && make
> cp -f ucpp $SRC_ROOT/ucpp/$INPATH/bin
> cd $SRC_ROOT/ucpp && deliver
>
> Regards,
> Tsutomu
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message