incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Rist <andrew.r...@oracle.com>
Subject Re: Build break due to CRLF in some scripts on Windows?
Date Mon, 12 Dec 2011 18:09:41 GMT
Here is the proposed steps for the Windows 7 buildbot.
I provide it here both for helping with others trying to build on
Windows, and for wider review of the steps for our nightly build.
The intent is to create the 'default build' on Windows - any corrections
very welcome.

(the following is from infra jira 4197
<https://issues.apache.org/jira/browse/INFRA-4197> which also contains
machine build recipe)

    *** build commands on win - run inside a cygwin shell (from
    runbuild.bat) ***

    cd /cygdrive/c/apache
    "/cygdrive/c/Program Files/Microsoft Visual Studio
    9.0/VC/vcvarsall.bat"
    svn co https://svn.apache.org/repos/asf/incubator/ooo/trunk ooo
    cd ooo/main
    cp -rfv ../../main_xtra/* .
    autoconf
    ./configure --enable-verbose
    --with-dmake-url="http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
    --with-cl-home="/cygdrive/c/Progra~1/Microsoft Visual Studio 9.0/VC"
    --with-jdk-home="/cygdrive/c/PROGRA~1/Java/jdk1.6.0_29"
    --with-psdk-home="/cygdrive/c/PROGRA~1/Microsoft SDKs/Windows/v6.1"
    --with-directx-home="C:\PROGRA~1\Microsoft DirectX SDK (June 2010)"
    --with-ant-home="/cygdrive/c/ant" --without-junit
    ./bootstrap
    source winenv.Set.sh
    date
    dmake
    date
    cd ../..







On 12/12/2011 6:00 AM, Zhe Liu wrote:
> Does anybody build successfully on Windows? I tried today. Depressingļ¼
> First break because of CRLF in fetch_tarballs.sh. I converted CRLF to
> LF. Continued but broke again because bootstrap can't cd dmake_4.11.
> e00deccf8817eec85ab5c0268d5a7bfb-dmake_4.11.zip is unzipped to a
> directory named dmake without version suffix. Fixed it and finally I
> came to run dmake happily.
>
> oops! Error again. I guess it's caused by CRLF.
> -----------------------
> solenv deliver
> /cygdrive/d/workspace-oo/aoo/main/solenv/bin/deliver.pl: line 1:
> $':\r': command not found
>
> .....
> ------------------------
> My cygwin is Cygwin DLL 1.7.9-1.  What mode should I used? binary or
> text?  Actually the default is binary just like the guide.
>

-- 

Andrew Rist | Interoperability Architect
OracleCorporate Architecture Group
Redwood Shores, CA | 650.506.9847


Mime
View raw message