incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From J├╝rgen Schmidt <jogischm...@googlemail.com>
Subject Re: Is it time for a build machine?
Date Fri, 02 Dec 2011 08:12:19 GMT
On 12/2/11 8:12 AM, Ariel Constenla-Haile wrote:
> Hi Pedro,
>
> On Thu, Dec 01, 2011 at 07:09:57PM -0800, Pedro Giffuni wrote:
>> Hi Andrew and guys;
>>
>> By the place where the automated build is failing I think this
>> was caused by the BrOffice removal:
>
> may be not, the buildbot is failing since rev 1206967 according
> to http://ci.apache.org/builders/openofficeorg-nightly
>
>>
>> http://svn.apache.org/viewvc?view=revision&revision=1207925
>>
>> but instead of reverting I would prefer we take this chance
>> to find out how to get useful information from the build
>> (a log).
>
> Sure this breaks in every platform:
>
> dmake:  makefile.mk:  line 231:  Error: -- Missing targets or attributes in rule
>
> http://svn.apache.org/viewvc/incubator/ooo/trunk/main/instsetoo_native/util/makefile.mk?r1=1162288&r2=1207925&diff_format=h#l231
>
> by removing broffice_$i from
>
> $(foreach,i,$(alllangiso) broffice_$i) : $$@{$(PKGFORMAT:^".")}
>
> you are creating a target for every language (en-US the default) that
> does not exist. Instead of broffice_en-US you get en-US.
> You should remove the whole target.
>
i stumbled over the same problem and have already checked in a fix. 
There were some more place where broffice was referenced and have 
cleaned up this.

Maybe we can agree that we build at least on one platform before we 
commit changes ;-)

Juergen

>
> Regards


Mime
View raw message