incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: [BUILD]solaris build failed again.
Date Mon, 19 Dec 2011 16:19:52 GMT
Hi L'oiseau de mer,

On Mon, Dec 19, 2011 at 11:02:50PM +0800, L'oiseau de mer wrote:
> Today i try to build AOO with language pack: select all language.

oh this may take too loooong. May be it's better to try
--with-lang="es de fr it pt"
or a few more or less. (no need to add en-US)

> configure parametre is:
> ./configure --disable-mozilla
> --with-junit=/usr/jdk/jdk1.6.0_26/bin/junit-4.10.jar --disable-gtk
> --with-lang=ALL --disable-cups --with-build-version="003"
> --with-system-python
> 
> But when i exec build --all, it appear these error message:
> ==============================================
> build -- version: 275224
> 
> Fetching dependencies for module l10n from solver... failed
> 
> ERROR: incomplete dependencies!
> ==============================================

did you check out
https://svn-master.apache.org/repos/asf/incubator/ooo/trunk/extras/ ?

supposing you have the following layout:

trunk
  |--- main/
  |--- extras/
  |--- source_config

you need that source_config file. It's a plain text file with the
following content:

[repositories]
main=active
extras=active


This way the build environment finds the l10n module.

Hope it helps :)


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message