incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: GStreamer not optional
Date Mon, 19 Dec 2011 13:04:37 GMT
Hi Andre,

On Mon, Dec 19, 2011 at 01:37:43PM +0100, Andre Fischer wrote:
> >>>>BUILD FAILED: failed compile_2
> >>>>
> >>>>sincerely,
> >>>>  -The Buildbot
> >>>http://ci.apache.org/builders/openofficeorg-nightly/builds/41/steps/compile_2/logs/stdio
> >>>checking whether to build the GStreamer media backend... checking for
> >>>GSTREAMER... no
> >>>configure: error: requirements to build the GStreamer media backend not
> >>>met. Use --disable-gstreamer or install the missing packages
> >>>program finished with exit code 1
> >>Why did this just happen now?  What has changed?
> >>We have had many successful builds over the last few weeks, and the
> >>machine setup has not changed.
> >>Is this due to the category_b change?
> >
> >yes
> 
> I am sorry about this, but can you elaborate the connection?

GStreamer was disabled with enable_copyleft set to no by default:
http://svn.apache.org/viewvc/incubator/ooo/trunk/main/configure.in?revision=1213190&view=markup#l1252
Removing enable_copyleft left enable_gstreamer=yes
http://svn.apache.org/viewvc/incubator/ooo/trunk/main/configure.in?revision=1213190&view=markup#l214

Wether Gstreamer should be considered as copy-left or as a system
library is not clear yet, at least I didn't get any conclusion on this
thread http://s.apache.org/Pxk

IMO it should be disabled by default, but enabled in AOO builds (a release
in Linux with no audio and sound support is a no-go; Oracle understood
this, they built GStreamer by default and put the plugin in the brand
packages but without making the system GStreamer library a requirement;
for sure this has to be changed, may be moving the plugin to its own
package and adding the system requirement to the deb/rpm package).

Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message