incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: Help! JunitTest_framework_unoapi.mk:28: *** Malformed target-specific variable definition. Stop.
Date Fri, 16 Dec 2011 03:39:30 GMT
Hi Zhe Liu,

On Fri, Dec 16, 2011 at 10:43:47AM +0800, Zhe Liu wrote:
> Hi All,
> I always break because of the error when build on Windows XP. I
> mentioned before, nobody responsed on it.  I did a little search and
> found someone also encountered the problem.  I still have no clue how
> to resolve it.
> 
> JunitTest_framework_unoapi.mk:28: *** Malformed target-specific
> variable definition.  Stop.
> 
> To continue my build, I have to remove the lines related to Junitest.
> There are several module with the same error. It's annoying to
> workaround them all.   Could anybody help me?

there are different ways to work around this:

1. comment the part in Module_XXX.mk where the tests are included
2. surround this part with a condition, checking for OOO_JUNIT_JAR
3. disable the code in solenv/gbuild/JunitTest.mk with the check for
   OOO_JUNIT_JAR
4. disable gb_Module_add_subsequentcheck_targets with a similar check


I first tried (3), then (4). I'm not sure yet, I'll need to test this
further, but you can give it a try. The patch is a dirty mix of (3) and
(4).

The problem is not solved disabling junit in configure, because the issue
is not with compiling the unit tests, but with parsing the Makefiles
JunitTest_xxx_xxx.mk , so we have to find a way not to parse those files
(until we find the real bug here - my guess, a gmake one).

Testing the patch with 
]$ make -dsr --print-data-base --warn-undefined-variables 
shows that at least the Makefiles are not even parsed.

You should first unset OOO_JUNIT_JAR before compiling: 

]$ unset OOO_JUNIT_JAR


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message