incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pedro Giffuni <...@apache.org>
Subject Re: [BUILD]AOO build error in solaris
Date Mon, 19 Dec 2011 02:16:43 GMT
Hi,

I can fix No. 2, but No. 1 doesnt seem right.
Maybe there is a related patch in Solaris
repositories? Alternatively you could use
the system python.

Cheers,

Pedro.

--- Dom 18/12/11, L'oiseau de mer <oiseaumer@gmail.com> ha scritto:

> Da: L'oiseau de mer <oiseaumer@gmail.com>
> Oggetto: Re: [BUILD]AOO build error in solaris
> A: ooo-dev@incubator.apache.org
> Data: Domenica 18 dicembre 2011, 20:54
> Build Success in Solaris 10 with
> binfilter.
> I modify this file "main/solenv/inc/unxsoli4.mk" in line
> 47:
> ARCH_FLAGS*="-features=rvalueref"
> =================================================
> But i also modify these file for building pass.
> 1.main/python/unxsoli4.pro/misc/build/Python-2.6.1/Modules/getbuildinfo.c
> in final line:
> 
> const char *
> _Py_svnversion(void)
> {
> //      /* the following string can be
> modified by subwcrev.exe */
> //      static const char svnversion[] =
> SVNVERSION;
> //      if (svnversion[0] != '$')
> //              return
> svnversion;
> //      return "exported";
> }
> 
> 2.main/libxslt/unxsoli4.pro/misc/build/libxslt-1.1.26/libxslt/extra.c
> in line 246
> //#if defined(__GLIBC__)
>     lmt = gmt - timezone;
> //#else /* FreeBSD DOESN'T HAVE such side-ffect */
> //    lmt = gmt - local_tm->tm_gmtoff;
> //#endif
> 
> 
> 2011/12/18 L'oiseau de mer <oiseaumer@gmail.com>:
> > I use version 4.2. from here to download and install:
> > http://www.epmhome.org/software.php
> >
> > Ok,thanks, i continue tying......
> >
> > 2011/12/18 Ariel Constenla-Haile <arielch@apache.org>:
> >> Hi L'oiseau de mer,
> >>
> >> On Sun, Dec 18, 2011 at 09:21:03PM +0800, L'oiseau
> de mer wrote:
> >>> Thank you very much, this part i still build
> and deal with it.
> >>> Now i first report another problem,when i
> arrive the step that make packages.
> >>> It appear this message:(This is another build
> machine (solaris 11 express))
> >>> i check this dir
> "unxsoli4.pro/OpenOffice/pkg/install/en-US_witherror/packages/"
> >>> it always create two file (and 1 subdir):
> >>> 1. XXX/
> >>> 2. XXX-3.4.0-1-solaris-11-intel.pkg.gz
> >>> 3. XXX-3.4.0-1-solaris-11-intel.pkg.tgz
> >>>
> >>> I have tryed move one to other place, and
> progress can pass to another package,
> >>> but always need move one to other place, and
> start become circle infinite.......
> >>> (same package appear again)
> >>> But i don't know configure where for solving
> this problem.
> >>>
> >>>
> >>>
> **************************************************
> >>> ERROR: ERROR: More than one new package in
> directory
> >>>
> /UNIX-LAB/ooo/main/instsetoo_native/unxsoli4.pro/OpenOffice/pkg/install/en-US_inprogress/packages
> >>> (
> /UNIX-LAB/ooo/main/instsetoo_native/unxsoli4.pro/OpenOffice/pkg/install/en-US_inprogress/packages/ooobasis34-calc-3.4.0-1-solaris-11-intel.pkg.gz
> >>>
> /UNIX-LAB/ooo/main/instsetoo_native/unxsoli4.pro/OpenOffice/pkg/install/en-US_inprogress/packages/ooobasis34-calc
> >>>
> /UNIX-LAB/ooo/main/instsetoo_native/unxsoli4.pro/OpenOffice/pkg/install/en-US_inprogress/packages/ooobasis34-calc-3.4.0-1-solaris-11-intel.pkg.tgz)
> >>> in function: determine_new_packagename
> (packagepool)
> >>>
> >>>
> **************************************************
> >>>
> >>>
> **************************************************
> >>> ERROR: Saved logfile:
> >>>
> /UNIX-LAB/ooo/main/instsetoo_native/unxsoli4.pro/OpenOffice/pkg/logging/en-US/log_OOO340_en-US.log
> >>>
> **************************************************
> >>> Sun Dec 18 20:54:43 2011 (00:35 min.)
> >>> dmake:  Error code 255, while making
> 'openoffice_en-US.pkg'
> >>> ---* tg_merge.mk *---
> >>>
> >>> 1 module(s):
> >>>       instsetoo_native
> >>> need(s) to be rebuilt
> >>>
> >>> Reason(s):
> >>>
> >>> ERROR: error 65280 occurred while making
> >>> /UNIX-LAB/ooo/main/instsetoo_native/util
> >>>
> >>> When you have fixed the errors in that module
> you can resume the build
> >>> by running:
> >>>
> >>>       build --all:instsetoo_native
> >>
> >>
> >> what epm version are you using?
> >>
> >> Building AOO requires a *patched* epm 3.7 version
> >> http://www.epmhome.org/software.php?VERSION=4.2&FILE=epm/3.7/epm-3.7-source.tar.bz2
> >> patched with this patch:
> >> http://hg.services.openoffice.org/OOO340/raw-file/c904c1944462/epm/epm-3.7.patch
> >>
> >>
> >> Regards
> >> --
> >> Ariel Constenla-Haile
> >> La Plata, Argentina
> 

Mime
View raw message