incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerardo Gómez <gerardo.g...@gmail.com>
Subject No addRow method in XGridDataModel interface in Oo 3.4 beta
Date Tue, 15 Nov 2011 00:02:46 GMT
Hello.
I've developed an extension which uses the XGridDataModel (especifically a
grid). This extension works ok on Ooo 3.3, but when i try to use it in the
new version, the 3.4 beta, the dialog that has the grid doesn't work at
all. This message is shown when i try to display the dialog with the grid:

/opt/ooo-dev3/program/../basis-link/ure-link/lib/libstdc++.so.6: version
`GLIBCXX_3.4.11' not found (required by /usr/lib/libproxy.so.1)
Failed to load module: /usr/lib/gio/modules/libgiolibproxy.so
Exception in thread "Thread-175" java.lang.NoSuchMethodError:
com.sun.star.awt.grid.XGridDataModel.addRow(Ljava/lang/String;[Ljava/lang/Object;)V
        at util.OoGridDataModel.addRow(OoGridDataModel.java:43)
        at util.OoGridDataModel.addRow(OoGridDataModel.java:39)
        at
org.openoffice.gdocs.ui.dialogs.ImportDialog.getDocumentsGrid(ImportDialog.java:811)
        at
org.openoffice.gdocs.ui.dialogs.ImportDialog.initComponents(ImportDialog.java:319)
        at
org.openoffice.gdocs.ui.dialogs.ImportDialog.<init>(ImportDialog.java:257)
        at org.openoffice.gdocs.UNOGDocs$3.run(UNOGDocs.java:262)
        at java.lang.Thread.run(Thread.java:662)

I think that this problem has to do with the new version (maybe because it
is a beta).

Regards.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message