incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Bugzilla's xmlrpc interface not working - mod_perl vs cgi problem?
Date Tue, 29 Nov 2011 19:58:08 GMT
On 29/11/2011 16:21, Christian Lohmaier wrote:
> Once again, this time also to bugzilla-admin@apache.org - the problem
> remains, no working xmlrpc.

If you create an INFRA Jira ticket against the Bugzilla component this
won't get forgotten.

Mark

> 
> On Tue, Nov 8, 2011 at 12:42 PM, Christian Lohmaier
> <cloph@openoffice.org> wrote:
>> Hi *,
>>
>> just like the old instance of bugzilla over at Oracle, the instance on
>> apache has a broken xmlrpc setup.
>>
>> check with:
>> <<<<<<<
>> #!/usr/bin/python
>> import xmlrpclib
>> #proxy = xmlrpclib.ServerProxy("https://bugzilla.mozilla.org/xmlrpc.cgi")
>> proxy = xmlrpclib.ServerProxy("https://issues.apache.org/ooo/xmlrpc.cgi")
>> try:
>>       response = proxy.Bugzilla.version()
>>       print response
>> except xmlrpclib.Fault, err:
>>       print "A fault occurred"
>>       print "Fault code: %s" % err.faultCode
>>       print err.faultString
>>>>>>>>>
>>
>> Actual output:
>>
>> A fault occurred
>> Fault code: Client
>> Application failed during request deserialization:
>> no element found at line 1, column 0, byte -1 at
>> /usr/local/lib/perl5/site_perl/5.12.4/mach/XML/Parser.pm line 187
>>
>> Expected output something like:
>>
>> {'version': '4.0.2+'}
>>
>> Probably it is a mismatch between mod_perl and the cgi variant, as
>> described here:
>> https://bugzilla.mozilla.org/show_bug.cgi?id=600810
>>
>> So you might want to give
>> https://bug600810.bugzilla.mozilla.org/attachment.cgi?id=543783 a try
>> (or switch to mod_cgi)
>>
>> ciao
>> Christian


Mime
View raw message