incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <jogischm...@googlemail.com>
Subject Re: [IMPORTANT][INFO]: wiki problems
Date Wed, 02 Nov 2011 08:35:47 GMT
On 11/1/11 9:20 PM, TJ Frazier wrote:
> On 11/1/2011 07:42, Gavin McDonald wrote:
>>
>>
>>> -----Original Message-----
>>> From: Andre Fischer [mailto:af@a-w-f.de]
>>> Sent: Tuesday, 1 November 2011 9:07 PM
>>> To: ooo-dev@incubator.apache.org
>>> Subject: Re: [IMPORTANT][INFO]: wiki problems
>>>
>>> On 01.11.2011 11:57, TJ Frazier wrote:
>>>> On 11/1/2011 06:16, Jürgen Schmidt wrote:
>>>>> Hi,
>>>>>
>>>>> i have noticed a problem when changing my wiki profile.
>>>>> When i try to change for example my email address in my wiki profile
>>>>> i got a confirmation email containing a confirmation link. This link
>>>>> starts with "http://127.0.0.1/wiki/Special:ConfirmEmail/..." that
>>>>> can't work. Changing the localhost ip address to
>>>>> wiki.services.openoffice.org and everything works as expected.
>>>>>
>>>>> Maybe one of the admins can have a look on it. It can confuse new
>> users.
>>>>>
>>>>> Juergen
>>>>>
>>>>>
>>>> Hi, Jürgen,
>>>>
>>>> Yes, this is a problem which shows up in several places. I believe it
>>>> is related to the front-ending of Apache Traffic Server, since that IP
>>>> is the address of ATS. I am certain that the "magic word" (technical
>>>> term,
>>>> honest) "{{fullurl}}" is returning this instead of the desired string.
>>>>
>>>> Might I ask where you changed "the localhost ip address"? Maybe I can
>>>> fix that myself. Otherwise, it's a matter for installation parameters,
>>>> or PHP in the Parser Extension, and those are beyond my reach.
>>>
>>> Hi,
>>>
>>> I ran into the same problem.
>>>
>>> Just replace "http://127.0.0.1/wiki/Special:ConfirmEmail/..."
>>> with "http://wiki.services.openoffice.org/wiki/Special:ConfirmEmail/..."
>>
>> Yeah pretty sure this is ATS related, I'll take a look, might be a few
>> hours
>> though.
>>
>> Gav...
>
> Researched this at
> http://www.mediawiki.org/wiki/Manual:LocalSettings.php
>
> Pretty sure the problem is with $wgServer, which should read,
> "http://wiki.services.openoffice.org"
> This is an address for external use. This change is necessary, but may
> or may not be sufficient.

mmh, just a further idea. Would it be possible to change the URL in the 
future to wiki.openoffice.org and redirect the 
wiki.services.openoffice.org. The latter one was used only because it 
was not possible to host the wiki on a HH server and use the short URL. 
I can't remember the exact reasons but i think it was something with 
CollabNet where all the stuff was hosted at this time

The same for users.services.openoffice.org -> users.openoffice.org

Over time we will have migrated all this long URLs and references to it 
and our users will probably adapt and us the short ones as well.

Just an idea to clean up this ugly long URLs

Juergen



> /tj/
>>
>>>
>>> Regards,
>>> Andre
>
>


Mime
View raw message