incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Regina Henschel <rb.hensc...@t-online.de>
Subject Re: Need a current build for WinXP 32bit
Date Tue, 01 Nov 2011 19:41:54 GMT
Hi Ariel,

Ariel Constenla-Haile schrieb:
> Hi Regina,
>
> On Mon, Oct 31, 2011 at 03:41:35PM +0100, Regina Henschel wrote:
>> Hi all,
>>
>> I'm still testing the new OLE features Armin implemented. I got a
>> build from Ariel with
>>
>> http://mail-archives.apache.org/mod_mbox/incubator-ooo-dev/201110.mbox/%3C20111018005157.GB30463%40localhost%3E
>>
>> It shows some odd things with presentations.
>> (1) ppt with equations give "General input/output error"
>
> I can't reproduce this with ODP files with Math.
> It would be helpful if you can upload your test documents somewhere, so
> we can all use the same docs to test (I don't have MS Office in my
> virtual machine, so I can't test embedding MSO files).

I have uploaded four files to http://www.rhenschel.homepage.t-online.de/

I can open the ppt file without problems now and the MathType formulas 
are OK. (Remember to uncheck converting in Tools>Objects>Load/Save) 
Import from pptx is wrong. It should retain an OLE, but it generates an 
Metafile and an empty OLE.

I get problems with the PaintShopPro-OLE. In presentation mode the 
picture is missing, if the OLE object is rotated and sheared. Without 
that transformations the OLE-objects are shown correctly in presentation 
mode.

>
>> (2) Own odp shows red x-crosses in presentation mode.
>>
>> I do not see this with my own builds,
>
> (2) is due to the --enable-dbgutil switch
>
>> but my builds do not have full
>> OLE support, because I have to disable atl, because atl is not
>> possible with MSVC 2008 Express.
>>
>> So is there someone out, who can provide me an actual full build to test it?
>
>
> You can try
> http://dl.dropbox.com/u/17375654/OOo_3.4.0_Win_x86_install-arc_en-US.zip
>
> * it is a pro-build (no --enable-dbgutil), so you won't see (2)
> * it's an archived version, no installation required. If you need an
>    installer, let me know (this will have to wait until tomorrow).

Thanks. An archive version is fine. Otherwise I would have to do an 
administrative installation. That would be no problem, but one step 
more. So an archive version is really fine :)

Kind regards
Regina

>
> Configure switches:
>
> $ ./configure  --with-external-tar="Y:/ext_sources"
> --with-cl-home="/cygdrive/c/ARCHIV~1/MICROS~1.0/VC"
> --with-mspdb-path="/cygdrive/c/ARCHIV~1/MICROS~1.0/Common7/IDE"
> --with-frame-home="/cygdrive/c/ARCHIV~1/MICROS~3/Windows/v6.1"
> --with-psdk-home="/cygdrive/c/ARCHIV~1/MICROS~3/Windows/v6.1"
> --with-midl-path="/cygdrive/c/ARCHIV~1/MICROS~3/Windows/v6.1/Bin"
> --with-asm-home="/cygdrive/c/ARCHIV~1/MICROS~1.0/VC/bin"
> --with-csc-path="/cygdrive/c/WINDOWS/Microsoft.NET/Framework/v3.5"
> --with-jdk-home="/cygdrive/c/ARCHIV~1/Java/JDK16~2.0_1"
> --with-ant-home="/cygdrive/c/apache-ant-1.7.1"
> --enable-minimizer
> --enable-presenter-console
> --enable-pdfimport
> --enable-wiki-publisher
> --enable-report-builder
> --enable-verbose
> --enable-mysql-connector --with-libmysql-path="C:/ARCHIV~1/MySQL/MYSQLC~1.2"
> --with-package-format="installed"
> --with-directx-home="/cygdrive/c/ARCHIV~1/MI599E~1"
> --enable-binfilter
>
> Regards


Mime
View raw message