incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: [API] Re: No addRow method in XGridDataModel interface in Oo 3.4 beta
Date Wed, 16 Nov 2011 21:55:19 GMT
Hi Fernand,

On Tue, Nov 15, 2011 at 11:35:35AM +0100, Fernand Vanrie wrote:
> Ariel ,
> 
> As y do not know about  C++ and Java i stick to Basic :-)
> Thanks (as always) for the knowledge !
> 
> BTW , I am interested in the Gridcontrol , because the Datasource
> browser is not working with a connection made using the
> "DriverManger".
> 
> oManager = CreateUnoService("com.sun.star.sdbc.DriverManager")
> oConn = oManager.getConnectionWithInfo(sURL, oParms())
> 
> When using the "Database Context"  to get a connenction  , the
> DataSourceBrowser is working,
> 
> I am sure you can explain me why the DatasourceBrowser is not
> working with a connection made from the DriverManager !

How were you trying this? Were you trying to pass oConn as value for
"ActiveConnection" when loading the DSB?

According to the API scpec.
http://api.openoffice.org/docs/common/ref/com/sun/star/sdb/DataSourceBrowser.html

the DSB does not accept an "ActiveConnection", only these properties
from the DataAccessDescriptor
http://api.openoffice.org/docs/common/ref/com/sun/star/sdb/DataAccessDescriptor.html
are accepted:

* DataAccessDescriptor::DataSourceName
* DataAccessDescriptor::Command
* DataAccessDescriptor::CommandType
* optional DataAccessDescriptor::Selection
* optional DataAccessDescriptor::BookmarkSelection
* optional DataAccessDescriptor::ResultSet

notice that the DataSourceName is not optional, and no ActiveConnection
(== you have to give the name of a registered data source).


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message