incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <>
Subject Re: Problem when showing a dialog of a deployed extension
Date Mon, 07 Nov 2011 05:09:41 GMT
Hello Gerardo,

On Sun, Nov 06, 2011 at 10:06:29PM -0600, Gerardo Gómez wrote:
> Hello everyone.
> I have a problem when i try to show some dialogs of an extension i've
> modified. But this error has a peculiarity, it only happens with some
> dialogs, other dialogs can be showed. The error showed on the console is
> this one:
> [jni_uno bridge error] Java calling UNO
> method setText: [map_to_uno():string] null-ref given!
> java stack trace:
>         at
> Method)
>         at
>         at $Proxy36.setText(Unknown Source)
>         at util.OoTextField.setText(
>         at
> org.openoffice.gdocs.ui.LoginPanel.fillCredentials(
>         at
> org.openoffice.gdocs.ui.LoginPanel.readCreditionals(
>         at org.openoffice.gdocs.ui.LoginPanel.setSystem(
>         at
> org.openoffice.gdocs.ui.dialogs.UploadDialog.<init>(
>         at org.openoffice.gdocs.UNOGDocs$
>         at
> I'm developing the extension on NetBeans 6.8, deploying the OXT file on
> 3.3 and the dialog i try to show is from the UNO-AWT. If you
> have any idea how can i solve this problem would be really appreciated.

without seeing any code, it is hard to guess. Did you already set
a breakpoint at and see why you are sending the
message setText to a null object?

Ariel Constenla-Haile
La Plata, Argentina

View raw message