incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From J├╝rgen Schmidt <jogischm...@googlemail.com>
Subject Re: configure: error: X Development libraries not found
Date Thu, 06 Oct 2011 07:40:12 GMT
On Wed, Oct 5, 2011 at 9:50 PM, Pedro Giffuni <pfg@apache.org> wrote:

> Hi guys;
>
> This basic configuration was working yesterday:
>
> CPPFLAGS=-I/usr/local/include
> LDFLAGS=-L/usr/local/lib
> ./configure --disable-mozilla --without-junit --disable-odk
> --with-gperf=/usr/local/bin/gperf --with-gnu-patch=/usr/local/bin/gpatch
>
> But with today's update
> ...
> checking for IceConnectionNumber in -lICE... yes
> checking for XOpenDisplay in -lX11... no
> configure: error: X Development libraries not found
>
>
> I suspect Revision 1179185, but I don't have a smoking gun (yet).
>
>
the change was trivial and i don't think that it has influence on finding
the X libraries. But you can easy try it out.
But nevertheless i think it make sense to generate a fresh configure every
time you get an updated configure.in.

Juergen



> Just for reference:
>
> > file /usr/local/lib/libX11*
> /usr/local/lib/libX11-xcb.a:    current ar archive
> /usr/local/lib/libX11-xcb.la:   libtool library file
> /usr/local/lib/libX11-xcb.so:   symbolic link to `libX11-xcb.so.1'
> /usr/local/lib/libX11-xcb.so.1: ELF 64-bit LSB shared object, x86-64,
> version 1 (FreeBSD), dynamically linked, not stripped
> /usr/local/lib/libX11.a:        current ar archive
> /usr/local/lib/libX11.la:       libtool library file
> /usr/local/lib/libX11.so:       symbolic link to `libX11.so.6'
> /usr/local/lib/libX11.so.6:     ELF 64-bit LSB shared object, x86-64,
> version 1 (FreeBSD), dynamically linked, not stripped
>
> Cheers,
>
> Pedro.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message